summaryrefslogtreecommitdiffstats
path: root/make/bzip2.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-13 06:02:20 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-13 06:02:20 +0000
commit620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d (patch)
treeaa08afb7d58fabed8f365bf373751992b792680c /make/bzip2.mk
parent192bace39e7c0fe5c4ccf9add25b67cb37f8abdc (diff)
downloadbuildroot-novena-620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d.tar.gz
buildroot-novena-620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d.zip
By popular demand, use 'sed' rather than 'perl' for doing
search and replace stuff. Hopefully we do not have any perl specific regexs that will be broken by this change, but it seems to be working thus far anyways,
Diffstat (limited to 'make/bzip2.mk')
-rw-r--r--make/bzip2.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/make/bzip2.mk b/make/bzip2.mk
index 187795f9d..60b6ceb32 100644
--- a/make/bzip2.mk
+++ b/make/bzip2.mk
@@ -21,8 +21,8 @@ bzip2-source: $(DL_DIR)/$(BZIP2_SOURCE)
$(BZIP2_DIR)/.unpacked: $(DL_DIR)/$(BZIP2_SOURCE)
$(BZIP2_CAT) $(DL_DIR)/$(BZIP2_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- perl -pi -e "s,ln \\$$\(,ln -sf \\$$\(,g" $(BZIP2_DIR)/Makefile
- perl -pi -e "s,ln -s (lib.*),ln -sf \$$1 ; ln -sf libbz2.so.1.0.2 libbz2.so,g" \
+ sed -ie "s,ln \\$$\(,ln -sf \\$$\(,g" $(BZIP2_DIR)/Makefile
+ sed -ie "s,ln -s (lib.*),ln -sf \$$1 ; ln -sf libbz2.so.1.0.2 libbz2.so,g" \
$(BZIP2_DIR)/Makefile-libbz2_so
touch $(BZIP2_DIR)/.unpacked