summaryrefslogtreecommitdiffstats
path: root/make/busybox.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-02-03 12:46:30 +0000
committerEric Andersen <andersen@codepoet.org>2003-02-03 12:46:30 +0000
commit7254ee77e54b4dc26a4bcb6393098bec41b5f7c7 (patch)
tree5a0ab4b20770ec85f73660e0e0e8fc2510c97de4 /make/busybox.mk
parentfa7f8b8ecaaf78f32ef6417a58530c421b4f99f4 (diff)
downloadbuildroot-novena-7254ee77e54b4dc26a4bcb6393098bec41b5f7c7.tar.gz
buildroot-novena-7254ee77e54b4dc26a4bcb6393098bec41b5f7c7.zip
Be really cereful to ensure udhcp.script is executable
Diffstat (limited to 'make/busybox.mk')
-rw-r--r--make/busybox.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/make/busybox.mk b/make/busybox.mk
index 600266fd4..bdbccafa0 100644
--- a/make/busybox.mk
+++ b/make/busybox.mk
@@ -51,6 +51,8 @@ $(BUSYBOX_DIR)/busybox: $(BUSYBOX_DIR)/.configured
$(TARGET_DIR)/bin/busybox: $(BUSYBOX_DIR)/busybox
$(MAKE) CROSS="$(TARGET_CROSS)" PREFIX="$(TARGET_DIR)" -C $(BUSYBOX_DIR) install
+ # Just in case
+ -chmod a+x $(TARGET_DIR)/usr/share/udhcpc/default.script
busybox: uclibc $(TARGET_DIR)/bin/busybox