summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2003-11-17 01:29:27 +0000
committerManuel Novoa III <mjn3@codepoet.org>2003-11-17 01:29:27 +0000
commit8162065d968b219e01628d5118683ba41da6c121 (patch)
treeb5f5dd01922499040ecf15a6dfe4502423982e05 /Makefile
parent7bfc5d37f49fc702a680e34d87783ba4082717df (diff)
downloadbuildroot-novena-8162065d968b219e01628d5118683ba41da6c121.tar.gz
buildroot-novena-8162065d968b219e01628d5118683ba41da6c121.zip
Fix most things when large file support is not configured.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5a7d7aad7..6aaf9fa41 100644
--- a/Makefile
+++ b/Makefile
@@ -210,6 +210,10 @@ ifeq ($(ENABLE_LOCALE),true)
EXTRA_GCC_CONFIG_OPTIONS += --enable-clocale=gnu
endif
+ifneq ($(BUILD_WITH_LARGEFILE),true)
+DISABLE_LARGEFILE= --disable-largefile
+endif
+
HOSTCC:=gcc
BASE_DIR:=${shell pwd}
SOURCE_DIR:=$(BASE_DIR)/sources