summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Sheridan <Tim.Sheridan@imgtec.com>2012-11-26 01:26:04 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-30 00:01:17 -0800
commitfc50f0c372d8c49dc713b11e756c1d940163b496 (patch)
treee8432a4944fe6d1605257e81f441bd15728f019d
parentb17c7963890354d2cffdda2f16eeeaf4c1288e99 (diff)
downloadbuildroot-novena-fc50f0c372d8c49dc713b11e756c1d940163b496.tar.gz
buildroot-novena-fc50f0c372d8c49dc713b11e756c1d940163b496.zip
gstreamer: Added option to disable plugin registry.
The plugin registry can take a while to be generated when GStreamer is initialized. Turning it off can speed up up GStreamer application launch times. Default behaviour is unchanged. Signed-off-by: Tim Sheridan <tim.sheridan@imgtec.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/multimedia/gstreamer/Config.in14
-rw-r--r--package/multimedia/gstreamer/gstreamer.mk3
2 files changed, 13 insertions, 4 deletions
diff --git a/package/multimedia/gstreamer/Config.in b/package/multimedia/gstreamer/Config.in
index 4d279b8b1..9a6748106 100644
--- a/package/multimedia/gstreamer/Config.in
+++ b/package/multimedia/gstreamer/Config.in
@@ -12,9 +12,17 @@ config BR2_PACKAGE_GSTREAMER_GST_DEBUG
default y
depends on BR2_PACKAGE_GSTREAMER
help
- Enable support for the gst-debug tracing functionality
- in gstreamer. This has limited CPU overhead, but does
- increase the rootfs size somewhat.
+ Enable support for the gst-debug tracing functionality in gstreamer.
+ This has limited CPU overhead, but does increase the rootfs size
+ somewhat.
+
+config BR2_PACKAGE_GSTREAMER_PLUGIN_REGISTRY
+ bool "enable plugin registry"
+ default y
+ depends on BR2_PACKAGE_GSTREAMER
+ help
+ Enable support for the GStreamer plugin registry. This may increase
+ the launch-time for a GStreamer application.
comment "gstreamer requires a toolchain with WCHAR support"
depends on !BR2_USE_WCHAR
diff --git a/package/multimedia/gstreamer/gstreamer.mk b/package/multimedia/gstreamer/gstreamer.mk
index a9841b17c..b87f0294f 100644
--- a/package/multimedia/gstreamer/gstreamer.mk
+++ b/package/multimedia/gstreamer/gstreamer.mk
@@ -21,7 +21,8 @@ GSTREAMER_CONF_OPT = \
--disable-tests \
--disable-failing-tests \
--disable-loadsave \
- $(if $(BR2_PACKAGE_GSTREAMER_GST_DEBUG),,--disable-gst-debug)
+ $(if $(BR2_PACKAGE_GSTREAMER_GST_DEBUG),,--disable-gst-debug) \
+ $(if $(BR2_PACKAGE_GSTREAMER_PLUGIN_REGISTRY),,--disable-registry)
GSTREAMER_DEPENDENCIES = libglib2 host-pkgconf