summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVellemans Noel <noel.vellemans@visionbms.com>2012-11-17 12:24:00 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-17 23:41:41 +0100
commite445f54bc74ea762a2444cf92be0864e639027a3 (patch)
tree1bf5c17a7cad9a309aa4a3de70984fbaa7d592a4
parentcd4d6ff77cdabe60f3dd185d4101cb70eafb25a7 (diff)
downloadbuildroot-novena-e445f54bc74ea762a2444cf92be0864e639027a3.tar.gz
buildroot-novena-e445f54bc74ea762a2444cf92be0864e639027a3.zip
libxml2: add support for building host library with python support
Patch based on the initial work of Will Wagner (Thanks Will). libxml2 host library with python support is required to build mesa3d (7.10.1) Signed-off-by: Vellemans Noel <noel.vellemans@visionbms.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/libxml2/Config.in3
-rw-r--r--package/libxml2/libxml2.mk10
2 files changed, 12 insertions, 1 deletions
diff --git a/package/libxml2/Config.in b/package/libxml2/Config.in
index ebd63fe54..ea62663dd 100644
--- a/package/libxml2/Config.in
+++ b/package/libxml2/Config.in
@@ -4,3 +4,6 @@ config BR2_PACKAGE_LIBXML2
XML C Parser
http://xmlsoft.org/
+
+config BR2_PACKAGE_HOST_LIBXML2_PYTHON
+ bool \ No newline at end of file
diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
index 71f2bd15b..fde3735b8 100644
--- a/package/libxml2/libxml2.mk
+++ b/package/libxml2/libxml2.mk
@@ -26,7 +26,15 @@ LIBXML2_POST_INSTALL_STAGING_HOOKS += LIBXML2_STAGING_LIBXML2_CONFIG_FIXUP
HOST_LIBXML2_DEPENDENCIES = host-pkgconf
-HOST_LIBXML2_CONF_OPT = --without-debug --without-python
+HOST_LIBXML2_CONF_OPT = --without-debug
+
+ifeq ($(BR2_PACKAGE_HOST_LIBXML2_PYTHON),y)
+HOST_LIBXML2_DEPENDENCIES += host-python
+HOST_LIBXML2_CONF_OPT += --with-python=$(HOST_DIR)/usr
+else
+HOST_LIBXML2_CONF_OPT += --without-python
+endif
+
define LIBXML2_REMOVE_CONFIG_SCRIPTS
$(RM) -f $(TARGET_DIR)/usr/bin/xml2-config