summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRico Bachmann <bachmann@tofwerk.com>2011-10-14 11:16:34 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-29 20:37:58 +0200
commitc34d753008aa174e700413eeaf070ff382efe02b (patch)
tree30c60159ef5977089fef2df95edfc62937873cf3
parent9e3dac50454f17f8d1890dc7f2c7fcefbd929416 (diff)
downloadbuildroot-novena-c34d753008aa174e700413eeaf070ff382efe02b.tar.gz
buildroot-novena-c34d753008aa174e700413eeaf070ff382efe02b.zip
package: add libfcgi fast cgi library.
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Rico Bachmann <bachmann@tofwerk.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/Config.in1
-rw-r--r--package/libfcgi/Config.in6
-rw-r--r--package/libfcgi/libfcgi.mk12
3 files changed, 19 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 4dcae531e..2ea334a94 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -359,6 +359,7 @@ source "package/libcurl/Config.in"
source "package/libdnet/Config.in"
source "package/libesmtp/Config.in"
source "package/libeXosip2/Config.in"
+source "package/libfcgi/Config.in"
source "package/libidn/Config.in"
source "package/liboauth/Config.in"
source "package/libmicrohttpd/Config.in"
diff --git a/package/libfcgi/Config.in b/package/libfcgi/Config.in
new file mode 100644
index 000000000..a622ec365
--- /dev/null
+++ b/package/libfcgi/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBFCGI
+ bool "libfcgi"
+ help
+ FCGI, a fastcgi developer library for C/C++
+
+ http://www.fastcgi.com/
diff --git a/package/libfcgi/libfcgi.mk b/package/libfcgi/libfcgi.mk
new file mode 100644
index 000000000..46251655d
--- /dev/null
+++ b/package/libfcgi/libfcgi.mk
@@ -0,0 +1,12 @@
+##############################################################################
+#
+# libfcgi
+#
+##############################################################################
+LIBFCGI_VERSION = 2.4.0
+LIBFCGI_SOURCE = fcgi-$(LIBFCGI_VERSION).tar.gz
+LIBFCGI_SITE = http://www.fastcgi.com/dist
+LIBFCGI_INSTALL_STAGING = YES
+LIBFCGI_CONF_ENV = LDFLAGS="$(TARGET_LDFLAGS) -lm"
+
+$(eval $(call AUTOTARGETS))