summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-02-14 12:20:38 +0000
committerEric Andersen <andersen@codepoet.org>2003-02-14 12:20:38 +0000
commitb2c6fe8f7843b96ddbf60ff49a63b13dcea4994c (patch)
treea756a0869c8965c6f23213aa442a021611b31a1c
parent370fb2a3ce0472611660c6a0c44ab84b5403805d (diff)
downloadbuildroot-novena-b2c6fe8f7843b96ddbf60ff49a63b13dcea4994c.tar.gz
buildroot-novena-b2c6fe8f7843b96ddbf60ff49a63b13dcea4994c.zip
Remove unwanted docs
-rw-r--r--make/autoconf.mk3
-rw-r--r--make/automake.mk3
-rw-r--r--make/gdb.mk2
-rw-r--r--make/gdbserver.mk2
-rw-r--r--make/libtool.mk3
-rw-r--r--make/m4.mk3
6 files changed, 12 insertions, 4 deletions
diff --git a/make/autoconf.mk b/make/autoconf.mk
index 92b4df36d..fe11b2c7d 100644
--- a/make/autoconf.mk
+++ b/make/autoconf.mk
@@ -55,7 +55,8 @@ $(TARGET_DIR)/$(AUTOCONF_TARGET_BINARY): $(AUTOCONF_DIR)/bin/$(AUTOCONF_BINARY)
mandir=$(TARGET_DIR)/usr/man \
includedir=$(TARGET_DIR)/usr/include \
-C $(AUTOCONF_DIR) install;
- rm -rf $(TARGET_DIR)/share/locale
+ rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+ $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
autoconf: uclibc $(TARGET_DIR)/$(AUTOCONF_TARGET_BINARY)
diff --git a/make/automake.mk b/make/automake.mk
index bc226c10f..6d4bbaa7d 100644
--- a/make/automake.mk
+++ b/make/automake.mk
@@ -56,7 +56,8 @@ $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY): $(AUTOMAKE_DIR)/$(AUTOMAKE_BINARY)
mandir=$(TARGET_DIR)/usr/man \
includedir=$(TARGET_DIR)/usr/include \
-C $(AUTOMAKE_DIR) install;
- rm -rf $(TARGET_DIR)/share/locale
+ rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+ $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
touch -c $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY)
automake: uclibc $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY)
diff --git a/make/gdb.mk b/make/gdb.mk
index 5b6650af7..8d54f8226 100644
--- a/make/gdb.mk
+++ b/make/gdb.mk
@@ -49,6 +49,8 @@ $(GDB_DIR)/gdb/gdb: $(GDB_DIR)/.configured
$(TARGET_DIR)/usr/bin/gdb: $(GDB_DIR)/gdb/gdb
install -c $(GDB_DIR)/gdb/gdb $(TARGET_DIR)/usr/bin/gdb
+ rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+ $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
gdb: $(TARGET_DIR)/usr/bin/gdb
diff --git a/make/gdbserver.mk b/make/gdbserver.mk
index c1ef1f1aa..bafd4d9e1 100644
--- a/make/gdbserver.mk
+++ b/make/gdbserver.mk
@@ -42,6 +42,8 @@ $(GDB_WDIR)/gdbserver: $(GDB_WDIR)/.configured
$(TARGET_DIR)/usr/bin/gdbserver: $(GDB_WDIR)/gdbserver
install -c $(GDB_WDIR)/gdbserver $(TARGET_DIR)/usr/bin/gdbserver
+ rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+ $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
gdbserver: $(TARGET_DIR)/usr/bin/gdbserver
diff --git a/make/libtool.mk b/make/libtool.mk
index 6043f5285..126b720d8 100644
--- a/make/libtool.mk
+++ b/make/libtool.mk
@@ -59,7 +59,8 @@ $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY): $(LIBTOOL_DIR)/$(LIBTOOL_BINARY)
-C $(LIBTOOL_DIR) install;
perl -pi -e "s,^CC.*,CC=\"/usr/bin/gcc\"," $(TARGET_DIR)/usr/bin/libtool
perl -pi -e "s,^LD.*,LD=\"/usr/bin/ld\"," $(TARGET_DIR)/usr/bin/libtool
- rm -rf $(TARGET_DIR)/share/locale
+ rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+ $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
libtool: uclibc $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY)
diff --git a/make/m4.mk b/make/m4.mk
index 8be5ddedb..e435386e9 100644
--- a/make/m4.mk
+++ b/make/m4.mk
@@ -47,7 +47,8 @@ $(TARGET_DIR)/$(M4_TARGET_BINARY): $(M4_DIR)/src/$(M4_BINARY)
mandir=$(TARGET_DIR)/usr/man \
includedir=$(TARGET_DIR)/usr/include \
-C $(M4_DIR) install;
- rm -rf $(TARGET_DIR)/share/locale
+ rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+ $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
m4: uclibc $(TARGET_DIR)/$(M4_TARGET_BINARY)