summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-07-18 23:43:58 +0000
committerEric Andersen <andersen@codepoet.org>2006-07-18 23:43:58 +0000
commit98bc6dac2abdd81a0f6cb504ffdcd4bd6ae77e2f (patch)
treee002dd54611f7cd6da28460af6492072b218da86
parent8aa5dc41389d61853ab79d66bf4723b6931763f8 (diff)
downloadbuildroot-novena-98bc6dac2abdd81a0f6cb504ffdcd4bd6ae77e2f.tar.gz
buildroot-novena-98bc6dac2abdd81a0f6cb504ffdcd4bd6ae77e2f.zip
configuring uClibc depends on first having kernel headers in place
-rw-r--r--Makefile2
-rw-r--r--toolchain/uClibc/uclibc.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index c181aa7cc..e9d0ab8e2 100644
--- a/Makefile
+++ b/Makefile
@@ -43,7 +43,7 @@ ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
# along with the packages to build for the target.
#
##############################################################
-TARGETS:=kernel-headers uclibc-configured binutils gcc uclibc-target-utils
+TARGETS:=uclibc-configured binutils gcc uclibc-target-utils
include toolchain/Makefile.in
include package/Makefile.in
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 2caceebb4..0cbefd8cd 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -68,7 +68,7 @@ $(UCLIBC_DIR)/.unpacked: $(DL_DIR)/$(UCLIBC_SOURCE)
touch $(UCLIBC_DIR)/.unpacked
uclibc-configured: $(UCLIBC_DIR)/.configured
-$(UCLIBC_DIR)/.configured: dependencies $(UCLIBC_DIR)/.unpacked
+$(UCLIBC_DIR)/.configured: dependencies kernel-headers $(UCLIBC_DIR)/.unpacked
cp $(UCLIBC_CONFIG_FILE) $(UCLIBC_DIR)/.config
$(SED) 's,^CROSS_COMPILER_PREFIX=.*,CROSS_COMPILER_PREFIX="$(TARGET_CROSS)",g' \
-e 's,# TARGET_$(UCLIBC_TARGET_ARCH) is not set,TARGET_$(UCLIBC_TARGET_ARCH)=y,g' \