summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-08-30 23:34:21 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-08-30 23:34:21 +0200
commit939c24d2a496452306aa25e3a19a8200cd950dac (patch)
treee56140df50d992208a6738149e1759ff9183cc75
parent40f8f3ff1d7582e1a2d92c707a57582e7dccbb54 (diff)
parent4ccde7fabbeb41472a0e662be4bc60707e099a02 (diff)
downloadbuildroot-novena-939c24d2a496452306aa25e3a19a8200cd950dac.tar.gz
buildroot-novena-939c24d2a496452306aa25e3a19a8200cd950dac.zip
Merge branch 'for-2010.08-3' of git://git.busybox.net/~tpetazzoni/git/buildroot
-rw-r--r--Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index d37d81f64..462d974d2 100644
--- a/Makefile
+++ b/Makefile
@@ -400,13 +400,17 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
rm -rf $(TARGET_DIR)/usr/share/gtk-doc
endif
find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
+ mkdir -p $(TARGET_DIR)/etc
+ # Mandatory configuration file and auxilliary cache directory
+ # for recent versions of ldconfig
+ touch $(TARGET_DIR)/etc/ld.so.conf
+ mkdir -p $(TARGET_DIR)/var/cache/ldconfig
if [ -x "$(TARGET_CROSS)ldconfig" ]; \
then \
- $(TARGET_CROSS)ldconfig -r $(TARGET_DIR) 2>/dev/null; \
+ $(TARGET_CROSS)ldconfig -r $(TARGET_DIR); \
else \
- /sbin/ldconfig -r $(TARGET_DIR) 2>/dev/null; \
+ /sbin/ldconfig -r $(TARGET_DIR); \
fi
- mkdir -p $(TARGET_DIR)/etc
echo $(BR2_VERSION)$(shell $(TOPDIR)/scripts/setlocalversion) > \
$(TARGET_DIR)/etc/br-version