summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2012-10-19 03:13:52 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-03 12:06:07 +0100
commit87422ed7e5a11bed94cd72ef80d1e5e1970c17fd (patch)
treef487895819042c6809a02edb15494f0dcbf49ecd
parentfa3afe2d81874b315759c1fb3b705ed54b15ce2c (diff)
downloadbuildroot-novena-87422ed7e5a11bed94cd72ef80d1e5e1970c17fd.tar.gz
buildroot-novena-87422ed7e5a11bed94cd72ef80d1e5e1970c17fd.zip
perl: prepare the removal of microperl
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/autoconf/Config.in2
-rw-r--r--package/autoconf/autoconf.mk2
-rw-r--r--package/automake/Config.in2
-rw-r--r--package/automake/automake.mk2
-rw-r--r--package/microperl/Config.in1
-rw-r--r--package/ntp/Config.in4
-rw-r--r--package/samba/Config.in4
7 files changed, 9 insertions, 8 deletions
diff --git a/package/autoconf/Config.in b/package/autoconf/Config.in
index 00b3e2c5d..5f2f14892 100644
--- a/package/autoconf/Config.in
+++ b/package/autoconf/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_AUTOCONF
bool "autoconf"
- select BR2_PACKAGE_MICROPERL
+ select BR2_PACKAGE_PERL
help
Extensible program for developing configure scripts. These
scripts handle all the mundane system/feature detection.
diff --git a/package/autoconf/autoconf.mk b/package/autoconf/autoconf.mk
index 3f84e3e0d..0cb50db50 100644
--- a/package/autoconf/autoconf.mk
+++ b/package/autoconf/autoconf.mk
@@ -10,7 +10,7 @@ AUTOCONF_SITE = $(BR2_GNU_MIRROR)/autoconf
AUTOCONF_CONF_ENV = EMACS="no" ac_cv_path_M4=$(HOST_DIR)/usr/bin/m4 \
ac_cv_prog_gnu_m4_gnu=no
-AUTOCONF_DEPENDENCIES = microperl host-m4
+AUTOCONF_DEPENDENCIES = host-m4 perl
HOST_AUTOCONF_CONF_ENV = ac_cv_path_M4=$(HOST_DIR)/usr/bin/m4 \
ac_cv_prog_gnu_m4_gnu=no
diff --git a/package/automake/Config.in b/package/automake/Config.in
index 935f1f145..9a9673a6e 100644
--- a/package/automake/Config.in
+++ b/package/automake/Config.in
@@ -1,7 +1,7 @@
config BR2_PACKAGE_AUTOMAKE
bool "automake"
select BR2_PACKAGE_AUTOCONF
- select BR2_PACKAGE_MICROPERL
+ select BR2_PACKAGE_PERL
help
Tool for automatically generating Makefile's for input to
configure scripts (made by autoconf).
diff --git a/package/automake/automake.mk b/package/automake/automake.mk
index 477b10b3f..faa1b36c3 100644
--- a/package/automake/automake.mk
+++ b/package/automake/automake.mk
@@ -9,7 +9,7 @@ AUTOMAKE_SITE = $(BR2_GNU_MIRROR)/automake
AUTOMAKE_LICENSE = GPLv2+
AUTOMAKE_LICENSE_FILES = COPYING
-AUTOMAKE_DEPENDENCIES = host-autoconf autoconf microperl
+AUTOMAKE_DEPENDENCIES = host-autoconf autoconf perl
HOST_AUTOMAKE_DEPENDENCIES = host-autoconf
diff --git a/package/microperl/Config.in b/package/microperl/Config.in
index 66bbedd77..19d104a69 100644
--- a/package/microperl/Config.in
+++ b/package/microperl/Config.in
@@ -2,6 +2,7 @@ config BR2_PACKAGE_MICROPERL
bool "microperl"
# needs fork()
depends on BR2_USE_MMU
+ depends on BR2_DEPRECATED
help
Perl without operating-specific functions such as readdir.
diff --git a/package/ntp/Config.in b/package/ntp/Config.in
index 599659609..ec5dbbb40 100644
--- a/package/ntp/Config.in
+++ b/package/ntp/Config.in
@@ -20,7 +20,7 @@ config BR2_PACKAGE_NTP_NTP_KEYGEN
config BR2_PACKAGE_NTP_NTP_WAIT
bool "ntp-wait"
- depends on BR2_PACKAGE_MICROPERL
+ depends on BR2_PACKAGE_PERL
help
ntp-wait waits until the locally running ntpd is in state 4
(synchronized). This could be useful at boot time, to delay the
@@ -59,7 +59,7 @@ config BR2_PACKAGE_NTP_NTPSNMPD
config BR2_PACKAGE_NTP_NTPTRACE
bool "ntptrace"
- depends on BR2_PACKAGE_MICROPERL
+ depends on BR2_PACKAGE_PERL
help
ntptrace is a perl script that uses the ntpq utility program to
follow the chain of NTP servers from a given host back to the
diff --git a/package/samba/Config.in b/package/samba/Config.in
index 928b40bd3..b4028b167 100644
--- a/package/samba/Config.in
+++ b/package/samba/Config.in
@@ -36,12 +36,12 @@ config BR2_PACKAGE_SAMBA_FINDSMB
default y
depends on BR2_PACKAGE_SAMBA_SMBCLIENT
depends on BR2_PACKAGE_SAMBA_NMBLOOKUP
- depends on BR2_PACKAGE_MICROPERL
+ depends on BR2_PACKAGE_PERL
help
Script to browse network
comment "findsmb - disabled (requires nmblookup, smbclient and perl)"
- depends on !BR2_PACKAGE_SAMBA_SMBCLIENT || !BR2_PACKAGE_SAMBA_NMBLOOKUP || !BR2_PACKAGE_MICROPERL
+ depends on !BR2_PACKAGE_SAMBA_SMBCLIENT || !BR2_PACKAGE_SAMBA_NMBLOOKUP || !BR2_PACKAGE_PERL
config BR2_PACKAGE_SAMBA_NET
bool "net"