summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-06-11 13:07:03 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-06-11 13:07:03 +0000
commit871896a93eb54f4d354cad5462e045cb74860a63 (patch)
tree27b5501ea6f5b7471cc6e596774bc7b77a98a137
parentfc084dfefe7db7069e435f9ab453fbe7f6f02220 (diff)
downloadbuildroot-novena-871896a93eb54f4d354cad5462e045cb74860a63.tar.gz
buildroot-novena-871896a93eb54f4d354cad5462e045cb74860a63.zip
u-boot: evaluate U_BOOT_ARCH at use time, rather than Makefile parse time
U_BOOT_ARCH seems to race with KERNEL_ARCH in some situations, so it end up empty. It's only used once, so fix it by using a use-time evaluated variable instead (=).
-rw-r--r--target/u-boot/Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index 6ba5c0f10..541e71f78 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -12,7 +12,7 @@ U_BOOT_CAT:=$(BZCAT)
U_BOOT_BIN:=u-boot.bin
U_BOOT_TOOLS_BIN:=mkimage
# u-boot still uses arch=ppc for powerpc
-U_BOOT_ARCH:=$(shell echo $(KERNEL_ARCH)|$(HOST_SED_DIR)/bin/sed 's/powerpc/ppc/')
+U_BOOT_ARCH=$(shell echo $(KERNEL_ARCH)|$(HOST_SED_DIR)/bin/sed 's/powerpc/ppc/')
ifneq ($(BR2_TARGET_U_BOOT_CONFIG_BOARD),)
U_BOOT_INC_CONF_FILE:=$(U_BOOT_DIR)/include/configs/$(subst _config,,$(BR2_TARGET_U_BOOT_CONFIG_BOARD)).h