summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Porcedda <fabio.porcedda@gmail.com>2012-09-10 00:02:57 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-29 09:56:26 +0200
commit7bcb494dcc21f9f8a2bd32d0f6425bbe2b63f5ae (patch)
tree948cecac7d87b2eec795a8de9b9567f21709994a
parent820cf3715248f26de533ccd6b6bc178142f69814 (diff)
downloadbuildroot-novena-7bcb494dcc21f9f8a2bd32d0f6425bbe2b63f5ae.tar.gz
buildroot-novena-7bcb494dcc21f9f8a2bd32d0f6425bbe2b63f5ae.zip
external-toolchain: add Sourcery CodeBench ARM 2012.03
Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--toolchain/toolchain-external/Config.in22
-rw-r--r--toolchain/toolchain-external/ext-tool.mk3
2 files changed, 25 insertions, 0 deletions
diff --git a/toolchain/toolchain-external/Config.in b/toolchain/toolchain-external/Config.in
index 85b8843e2..94ae73521 100644
--- a/toolchain/toolchain-external/Config.in
+++ b/toolchain/toolchain-external/Config.in
@@ -83,6 +83,27 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_05
To use this toolchain, you must disable soft float usage.
+config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
+ bool "Sourcery CodeBench ARM 2012.03"
+ depends on BR2_arm
+ select BR2_TOOLCHAIN_EXTERNAL_GLIBC
+ select BR2_INSTALL_LIBSTDCPP
+ help
+ Sourcery CodeBench toolchain for the ARM architecture, from
+ Mentor Graphics. It uses gcc 4.6.3, binutils 2.21.53, glibc
+ 2.15 and gdb 7.2.50, kernel headers 3.2.10. It has support
+ for the following variants:
+ - ARMv5TE, little endian, soft-float, glibc
+ Select ARM926T, ARM10T, XScale or another ARMv5 core
+ Select BR2_SOFT_FLOAT
+ - ARMv4T, little endian, soft-float, glibc
+ Select ARM720T, ARM920T, ARM922T or another ARMv4 core
+ Select BR2_SOFT_FLOAT
+ - ARMv7-A, Thumb 2, little endian, soft-float, glibc
+ Select Cortex-A8, Cortex-A9 or another ARMv7-A core
+ Select BR2_SOFT_FLOAT
+ Set BR2_TARGET_OPTIMIZATION to -mthumb
+
config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
bool "Sourcery CodeBench ARM 2011.09"
depends on BR2_arm
@@ -620,6 +641,7 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
+ default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
default "microblazeel-unknown-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEEL_V2
default "microblaze-unknown-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEBE_V2
default "mips-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index 5a7c03e76..43d747cad 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -187,6 +187,9 @@ TOOLCHAIN_EXTERNAL_SOURCE=arm-2011.03-41-arm-none-linux-gnueabi-i686-pc-linux-gn
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109),y)
TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/arm-none-linux-gnueabi/
TOOLCHAIN_EXTERNAL_SOURCE=arm-2011.09-70-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203),y)
+TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/arm-none-linux-gnueabi/
+TOOLCHAIN_EXTERNAL_SOURCE=arm-2012.03-57-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_05),y)
TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.05/+download/
TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.05-20120523_linux.tar.bz2