summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2012-12-11 01:10:07 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-16 01:18:57 +0100
commit71a4513e73ec8a3c3d1a18c328c867a8ba2eb471 (patch)
treef3b269e83f4dc42c6f4246e6e816387c581de64e
parentcb8efd3b4d94c83aefed6533e20b24961e9d054f (diff)
downloadbuildroot-novena-71a4513e73ec8a3c3d1a18c328c867a8ba2eb471.tar.gz
buildroot-novena-71a4513e73ec8a3c3d1a18c328c867a8ba2eb471.zip
host-libxml2: enable debug for mesa3d
The API generation script in mesa3d requires libxml2 to be built with debug, because it uses the lsCountNode function which is only available in debug mode. Note that this is the second "temporary" hack to make mesa3d work. See http://lists.busybox.net/pipermail/buildroot/2012-November/061936.html for possible more fundamental solutions. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/libxml2/libxml2.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
index fde3735b8..0c84652dd 100644
--- a/package/libxml2/libxml2.mk
+++ b/package/libxml2/libxml2.mk
@@ -26,7 +26,12 @@ LIBXML2_POST_INSTALL_STAGING_HOOKS += LIBXML2_STAGING_LIBXML2_CONFIG_FIXUP
HOST_LIBXML2_DEPENDENCIES = host-pkgconf
+# mesa3d uses functions that are only available with debug
+ifeq ($(BR2_PACKAGE_MESA3D),y)
+HOST_LIBXML2_CONF_OPT = --with-debug
+else
HOST_LIBXML2_CONF_OPT = --without-debug
+endif
ifeq ($(BR2_PACKAGE_HOST_LIBXML2_PYTHON),y)
HOST_LIBXML2_DEPENDENCIES += host-python