summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-21 13:18:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-23 20:34:32 +0100
commit570e1b77c285be7b19d0be3dda27853b06b58ae8 (patch)
tree6c4d020702fe82164f9562a2d18a754fbb1dcb16
parent405a7ecaa19d229e144062a338d5a3b8cd21c96c (diff)
downloadbuildroot-novena-570e1b77c285be7b19d0be3dda27853b06b58ae8.tar.gz
buildroot-novena-570e1b77c285be7b19d0be3dda27853b06b58ae8.zip
intltool: new package
This XML internationalization set of tools is required to build several of our packages, and may not be available on the host machine. Only the host variant has been tested. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/Config.in1
-rw-r--r--package/intltool/Config.in6
-rw-r--r--package/intltool/intltook.mk16
3 files changed, 23 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 00f3401ae..37cae2e83 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -46,6 +46,7 @@ source "package/pkg-config/Config.in"
source "package/readline/Config.in"
source "package/valgrind/Config.in"
source "package/pcre/Config.in"
+source "package/intltool/Config.in"
comment "Other stuff"
source "package/at/Config.in"
diff --git a/package/intltool/Config.in b/package/intltool/Config.in
new file mode 100644
index 000000000..94b34f7c4
--- /dev/null
+++ b/package/intltool/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_INTLTOOL
+ bool "intltool"
+ help
+ Utility scripts for internationalizing XML
+
+ http://www.freedesktop.org/wiki/Software/intltool \ No newline at end of file
diff --git a/package/intltool/intltook.mk b/package/intltool/intltook.mk
new file mode 100644
index 000000000..746ebb1d5
--- /dev/null
+++ b/package/intltool/intltook.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# intltool
+#
+#############################################################
+INTLTOOL_VERSION:=0.40.6
+INTLTOOL_SOURCE:=intltool-$(INTLTOOL_VERSION).tar.bz2
+INTLTOOL_SITE:=http://ftp.acc.umu.se/pub/GNOME/sources/intltool/0.40/
+
+HOST_INTLTOOL_DEPENDENCIES = host-libxml-parser-perl
+HOST_INTLTOOL_CONF_OPT = \
+ PERLLIB=$(HOST_DIR)/usr/lib/perl
+
+$(eval $(call AUTOTARGETS,package,intltool))
+$(eval $(call AUTOTARGETS,package,intltool,host))
+