summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-01-06 11:29:23 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-12 22:37:02 +0100
commit4f83232e8d307f6184900c6e4a99a5f76dc66fa4 (patch)
tree0b82125ec3f2bccb43384e2bdae75ffbce16958a
parentb6de4b198e3677fcb158fa780329321862b8d171 (diff)
downloadbuildroot-novena-4f83232e8d307f6184900c6e4a99a5f76dc66fa4.tar.gz
buildroot-novena-4f83232e8d307f6184900c6e4a99a5f76dc66fa4.zip
libsha1: new package
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/Config.in1
-rw-r--r--package/libsha1/Config.in9
-rw-r--r--package/libsha1/libsha1.mk15
3 files changed, 25 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index bd1db6b88..fcc248011 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -371,6 +371,7 @@ source "package/gnutls/Config.in"
source "package/libgcrypt/Config.in"
source "package/libgpg-error/Config.in"
source "package/libnss/Config.in"
+source "package/libsha1/Config.in"
source "package/nettle/Config.in"
source "package/ocf-linux/Config.in"
source "package/openssl/Config.in"
diff --git a/package/libsha1/Config.in b/package/libsha1/Config.in
new file mode 100644
index 000000000..5467a6c4c
--- /dev/null
+++ b/package/libsha1/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBSHA1
+ bool "libsha1"
+ help
+ libsha1 is a tiny library providing SHA1 implementation,
+ created for facilitating X server compilation on devices
+ when larger libraries containing SHA1 implementations
+ (OpenSSL, Mozilla NSS) are not needed.
+
+ https://github.com/dottedmag/libsha1
diff --git a/package/libsha1/libsha1.mk b/package/libsha1/libsha1.mk
new file mode 100644
index 000000000..e9658af4b
--- /dev/null
+++ b/package/libsha1/libsha1.mk
@@ -0,0 +1,15 @@
+#############################################################
+#
+# libsha1
+#
+#############################################################
+
+LIBSHA1_VERSION = 0.3
+LIBSHA1_SITE = http://github.com/dottedmag/libsha1/tarball/$(LIBSHA1_VERSION)
+LIBSHA1_INSTALL_STAGING = YES
+
+# We're getting the source code from Github, so there is no generated
+# configure script in the tarball.
+LIBSHA1_AUTORECONF = YES
+
+$(eval $(autotools-package))