summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-07-10 15:39:17 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2013-07-10 21:56:44 +0200
commit371c395b60d854a9b2f9e99f5d3243a6a8deeb41 (patch)
tree7c21a1c39ae64386aca3186d5a7ef99c57d52737
parent21d77aa3fedbfcc08421d41c8393611ebe7e0e39 (diff)
downloadbuildroot-novena-371c395b60d854a9b2f9e99f5d3243a6a8deeb41.tar.gz
buildroot-novena-371c395b60d854a9b2f9e99f5d3243a6a8deeb41.zip
python: remove idle sample
Also move smtpd.py removal to the global remove useless files define. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/python/python.mk11
1 files changed, 4 insertions, 7 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index 975d6f40c..ecea638d4 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -143,21 +143,18 @@ endef
PYTHON_POST_INSTALL_STAGING_HOOKS += PYTHON_FIXUP_LIBDIR
-# Bad shebang, normally not used
-define PYTHON_REMOVE_SMTPD
- rm -f $(TARGET_DIR)/usr/bin/smtpd.py
-endef
-
-PYTHON_POST_INSTALL_TARGET_HOOKS += PYTHON_REMOVE_SMTPD
-
#
# Remove useless files. In the config/ directory, only the Makefile
# and the pyconfig.h files are needed at runtime.
#
+# idle & smtpd.py have bad shebangs and are mostly samples
+#
define PYTHON_REMOVE_USELESS_FILES
+ rm -f $(TARGET_DIR)/usr/bin/idle
rm -f $(TARGET_DIR)/usr/bin/python$(PYTHON_VERSION_MAJOR)-config
rm -f $(TARGET_DIR)/usr/bin/python2-config
rm -f $(TARGET_DIR)/usr/bin/python-config
+ rm -f $(TARGET_DIR)/usr/bin/smtpd.py
for i in `find $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/config/ \
-type f -not -name pyconfig.h -a -not -name Makefile` ; do \
rm -f $$i ; \