summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-06-28 22:28:51 +0000
committerEric Andersen <andersen@codepoet.org>2004-06-28 22:28:51 +0000
commit285b2fa0ae520d822917674001f0aff4b9648355 (patch)
tree02897e7c73bc5dcff7ec2f989b1f732e95bb9f65
parentd385b6e3a2bd0a09bb2e3aa68c5c63d7b233ff39 (diff)
downloadbuildroot-novena-285b2fa0ae520d822917674001f0aff4b9648355.tar.gz
buildroot-novena-285b2fa0ae520d822917674001f0aff4b9648355.zip
Erik Karu writes:
Hi, this patch seems to be needed to compile tinyx with latest buildroot. Btw, any ideas isn't there anyone else using tinyx if I'm first to submit this obvious patch? Cheers, EK.
-rw-r--r--make/tinyx.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/make/tinyx.mk b/make/tinyx.mk
index 6c57e881f..cf059e4cb 100644
--- a/make/tinyx.mk
+++ b/make/tinyx.mk
@@ -49,7 +49,6 @@ TINYX_SITE:= http://intimate.handhelds.org/jacques/
TINYX_CF:=$(TINYX_DIR)/config/cf
#
# Some things that you may want to change.
-#
TINYX_XFBDEV:=$(TINYX_DIR)/programs/Xserver/Xfbdev
TINYX_CAT:=bzcat
TINYX_BINX:=$(TARGET_DIR)/usr/X11R6/bin/
@@ -62,10 +61,11 @@ $(DL_DIR)/$(TINYX_SOURCE):
$(WGET) -P $(DL_DIR) $(TINYX_SITE)/$(TINYX_SOURCE)
$(DL_DIR)/cross.def:
- $(WGET) -P $(DL_DIR) $(TINYX_SITE)/xcompile/tuxscreen/cross.def
+ $(WGET) -P $(DL_DIR) $(TINYX_SITE)/xcompile/tuxscreen/cross.def
+ $(SED) 's:arm-uclibc-:arm-linux-uclibc-:g' $(DL_DIR)/cross.def
$(DL_DIR)/host.def:
- $(WGET) -P $(DL_DIR) $(TINYX_SITE)/xcompile/tuxscreen/host.def
+ $(WGET) -P $(DL_DIR) $(TINYX_SITE)/xcompile/tuxscreen/host.def
#
# rule to make sure that we have the source, and it is configured.
@@ -75,6 +75,7 @@ $(TINYX_DIR)/.configure: $(DL_DIR)/$(TINYX_SOURCE) $(DL_DIR)/cross.def $(DL_DIR)
cat $(TINYX_PATCH) | patch -d $(TINYX_DIR) -p1
cp $(DL_DIR)/host.def $(TINYX_CF)/host.def
cp $(DL_DIR)/cross.def $(TINYX_CF)/cross.def
+ $(SED) 's,arm-uclibc-,$(ARCH)-linux-uclibc-,g' $(TINYX_CF)/cross.def
$(SED) 's:REPLACE_STAGING_DIR:$(STAGING_DIR):g' \
$(TINYX_CF)/cross.def \
$(TINYX_LDIR)/X11/Xlib.h