summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-03-05 15:30:12 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-03-05 15:30:12 +0100
commit0cab96376125ad88b4f28a649a54c601d1f4d772 (patch)
treee75036120d9cdb8f55e5325e83a8eb154856aaac
parent8296cf6c7ffa920ee9d37ac4695d52966fd1ecff (diff)
parentb927b5f3020918b574474b5fd80969fad023a837 (diff)
downloadbuildroot-novena-0cab96376125ad88b4f28a649a54c601d1f4d772.tar.gz
buildroot-novena-0cab96376125ad88b4f28a649a54c601d1f4d772.zip
Merge branch 'for-2011.05/pkg-stats-improvements' of git://git.busybox.net/~tpetazzoni/git/buildroot
-rwxr-xr-xscripts/pkg-stats58
1 files changed, 54 insertions, 4 deletions
diff --git a/scripts/pkg-stats b/scripts/pkg-stats
index 01af89de0..7bb292830 100755
--- a/scripts/pkg-stats
+++ b/scripts/pkg-stats
@@ -51,8 +51,10 @@ tr.correct td {
<tr>
<td rowspan=\"2\">Id</td>
<td rowspan=\"2\">Package</td>
+<td>Patch count</td>
<td colspan=\"2\" class=\"centered\">AUTOTARGETS</td>
<td colspan=\"2\" class=\"centered\">GENTARGETS</td>
+<td colspan=\"2\" class=\"centered\">CMAKETARGETS</td>
<td colspan=\"2\" class=\"centered\">manual</td>
<td rowspan=\"2\" class=\"centered\">Actions</td>
</tr>
@@ -63,22 +65,24 @@ tr.correct td {
<td class=\"centered\">target</td>
<td class=\"centered\">host</td>
<td class=\"centered\">target</td>
+<td class=\"centered\">host</td>
+<td class=\"centered\">target</td>
</tr>"
convert_to_generic_target=0
convert_to_generic_host=0
convert_to_autotools=0
+total_patch_count=0
cnt=1
for i in $(find package/ -name '*.mk') ; do
- if test $i = "package/mtd/mtd.mk" -o \
+ if test \
$i = "package/java/java.mk" -o \
- $i = "package/database/database.mk" -o \
- $i = "package/editors/editors.mk" -o \
$i = "package/games/games.mk" -o \
$i = "package/multimedia/multimedia.mk" -o \
$i = "package/customize/customize.mk" -o \
$i = "package/gnuconfig/gnuconfig.mk" -o \
+ $i = "package/matchbox/matchbox.mk" -o \
$i = "package/x11r7/x11r7.mk" ; then
echo "skipping $i" 1>&2
continue
@@ -88,6 +92,8 @@ for i in $(find package/ -name '*.mk') ; do
is_auto_host=0
is_auto_target=0
+ is_cmake_host=0
+ is_cmake_target=0
is_pkg_target=0
is_pkg_host=0
is_manual_target=0
@@ -109,6 +115,14 @@ for i in $(find package/ -name '*.mk') ; do
is_pkg_target=1
fi
+ if grep -E "\(call CMAKETARGETS,[^,]*,[^,]*,host\)" $i > /dev/null ; then
+ is_cmake_host=1
+ fi
+
+ if grep -E "\(call CMAKETARGETS,[^,]*,[^,]*(,target|)\)" $i > /dev/null ; then
+ is_cmake_target=1
+ fi
+
pkg=$(basename $i)
pkg=${pkg%.mk}
@@ -116,7 +130,7 @@ for i in $(find package/ -name '*.mk') ; do
is_manual_host=1
fi
- if test $is_pkg_target -eq 0 -a $is_auto_target -eq 0 ; then
+ if test $is_pkg_target -eq 0 -a $is_auto_target -eq 0 -a $is_cmake_target -eq 0; then
is_manual_target=1
fi
@@ -151,6 +165,22 @@ for i in $(find package/ -name '*.mk') ; do
echo "<td>$cnt</td>"
echo "<td>$i</td>"
+ package_dir=$(dirname $i)
+ patch_count=$(find ${package_dir} -name '*.patch' | wc -l)
+ total_patch_count=$(($total_patch_count+$patch_count))
+
+ if test $patch_count -lt 1 ; then
+ patch_count_color="#00ff00"
+ elif test $patch_count -lt 5 ; then
+ patch_count_color="#ffc600"
+ else
+ patch_count_color="#ff0000"
+ fi
+
+ echo "<td class=\"centered\" style=\"color: $patch_count_color; font-weight: bold;\">"
+ echo $patch_count
+ echo "</td>"
+
echo "<td class=\"centered\">"
if [ $is_auto_host -eq 1 ] ; then
echo "<b>YES</b>"
@@ -184,6 +214,22 @@ for i in $(find package/ -name '*.mk') ; do
echo "</td>"
echo "<td class=\"centered\">"
+ if [ $is_cmake_host -eq 1 ] ; then
+ echo "<b>YES</b>"
+ else
+ echo "NO"
+ fi
+ echo "</td>"
+
+ echo "<td class=\"centered\">"
+ if [ $is_cmake_target -eq 1 ] ; then
+ echo "<b>YES</b>"
+ else
+ echo "NO"
+ fi
+ echo "</td>"
+
+ echo "<td class=\"centered\">"
if [ $is_manual_host -eq 1 ] ; then
echo "<b>YES</b>"
else
@@ -228,6 +274,10 @@ echo "<td>Packages to convert to host autotools</td>"
echo "<td>$convert_to_host_autotools</td>"
echo "</tr>"
echo "<tr>"
+echo "<td>Number of patches in all packages</td>"
+echo "<td>$total_patch_count</td>"
+echo "</tr>"
+echo "<tr>"
echo "<td>TOTAL</td>"
echo "<td>$cnt</td>"
echo "</tr>"