summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-01 05:59:43 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-01 05:59:43 +0000
commit06d2c518561a4db2bd2f3156fed0be111f747966 (patch)
tree528642bc6b3a71e4a58e22131fe8633419e48224
parentb1f39829cda4f02998eb64b3e39001c87fe826d2 (diff)
downloadbuildroot-novena-06d2c518561a4db2bd2f3156fed0be111f747966.tar.gz
buildroot-novena-06d2c518561a4db2bd2f3156fed0be111f747966.zip
do not build valgrind for non-i386
-rw-r--r--make/valgrind.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/make/valgrind.mk b/make/valgrind.mk
index c7d89261c..924d21162 100644
--- a/make/valgrind.mk
+++ b/make/valgrind.mk
@@ -72,7 +72,11 @@ $(TARGET_DIR)/usr/bin/valgrind: $(VALGRIND_DIR)/coregrind/valgrind.so
#cp $(VALGRIND_DIR)/woody.supp $(TARGET_DIR)/usr/lib/valgrind/
touch -c $(TARGET_DIR)/usr/bin/valgrind
+ifeq ($(ARCH),i386)
valgrind: $(TARGET_DIR)/usr/bin/valgrind
+else
+valgrind:
+endif
valgrind-clean:
$(MAKE) -C $(VALGRIND_DIR) clean