aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dreamplug-uaputl/Makefile
diff options
context:
space:
mode:
authorArturo FilastoĢ€ <hellais@torproject.org>2011-08-19 10:51:07 +0200
committerArturo FilastoĢ€ <hellais@torproject.org>2011-08-19 10:51:07 +0200
commit11aaab578cc13910aca7a32d87072781056f30df (patch)
tree01c8473754e676d08b16b300c5889cfc8cfc9d19 /packages/dreamplug-uaputl/Makefile
parentdfe11c74fe59ceaa68778d80ce6a8a16227350f9 (diff)
parente3327c32629717ee81283b9813e5764e6fda2c2e (diff)
downloadtorouter-11aaab578cc13910aca7a32d87072781056f30df.tar.gz
torouter-11aaab578cc13910aca7a32d87072781056f30df.zip
Merge branch 'master' of ssh://git-rw.torproject.org/torouter
Diffstat (limited to 'packages/dreamplug-uaputl/Makefile')
-rwxr-xr-xpackages/dreamplug-uaputl/Makefile55
1 files changed, 0 insertions, 55 deletions
diff --git a/packages/dreamplug-uaputl/Makefile b/packages/dreamplug-uaputl/Makefile
deleted file mode 100755
index 4e33274..0000000
--- a/packages/dreamplug-uaputl/Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
-# File : uaputl/Makefile
-#
-# Copyright (C) 2008, Marvell International Ltd.
-# All Rights Reserved
-
-# Path to the top directory of the wlan distribution
-PATH_TO_TOP = ../..
-
-# Determine how we should copy things to the install directory
-ABSPATH := $(filter /%, $(INSTALLDIR))
-RELPATH := $(filter-out /%, $(INSTALLDIR))
-INSTALLPATH := $(ABSPATH)
-ifeq ($(strip $(INSTALLPATH)),)
-INSTALLPATH := $(PATH_TO_TOP)/$(RELPATH)
-endif
-
-# Override CFLAGS for application sources, remove __ kernel namespace defines
-CFLAGS := $(filter-out -D__%, $(EXTRA_CFLAGS))
-
-
-#CFLAGS += -DAP22 -fshort-enums
-CFLAGS += -Wall
-#ECHO = @
-LIBS = -lrt
-
-.PHONY: default tags all
-
-OBJECTS = uaputl.o uapcmd.o
-HEADERS = uaputl.h uapcmd.h
-
-TARGET = uaputl
-
-build default: $(TARGET)
- @cp -f $(TARGET) $(INSTALLPATH)
- @cp -rf config/* $(INSTALLPATH)
-
-
-all : tags default
-
-$(TARGET): $(OBJECTS) $(HEADERS)
- $(ECHO)$(CC) $(LIBS) -o $@ $(OBJECTS)
-
-%.o: %.c $(HEADERS)
- $(ECHO)$(CC) $(CFLAGS) -c -o $@ $<
-
-tags:
- ctags -R -f tags.txt
-
-clean:
- $(ECHO)$(RM) $(OBJECTS) $(TARGET)
- $(ECHO)$(RM) tags.txt
-
-# We add this install target to allow for installation
-install:
- install $(TARGET) $(DESTDIR)/usr/bin/$(TARGET)