aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@archive.org>2020-05-28 02:59:52 -0700
committerBryan Newbold <bnewbold@archive.org>2020-05-28 02:59:52 -0700
commit1a4906b89123f015dfb1337e384ebed696d09f5c (patch)
treec7fffed6df75307f88da6afc1f8c21d692aa8f91 /Cargo.toml
parenta5b0e918f886bb7977453a4b2a02b7643916cf89 (diff)
downloadaft-1a4906b89123f015dfb1337e384ebed696d09f5c.tar.gz
aft-1a4906b89123f015dfb1337e384ebed696d09f5c.zip
first rust experiments
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..e5428b2
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "aft"
+version = "0.1.0"
+authors = ["Bryan Newbold <bnewbold@robocracy.org>"]
+edition = "2018"
+
+[dependencies]
+#serde_json = "1.0"
+#bstr = "0.2"
+#structopt = "0.3"
+anyhow = "1.0"
+colored = "1.9"
+atty = "0.2"
+tabwriter = { version = "1.2", features = ["ansi_formatting"] }
+
+[dev-dependencies]
+assert_cmd = "1"
+
+[profile.release]
+lto = true
+codegen-units = 1
+opt-level = "z"
+panic = "abort"