aboutsummaryrefslogtreecommitdiffstats
path: root/python/pyproject.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@archive.org>2021-10-26 12:22:04 -0700
committerBryan Newbold <bnewbold@archive.org>2021-10-26 12:22:04 -0700
commitf67d870ba4ca9cecd0b75f106335997c813e9df4 (patch)
tree2e78606c76b02bb9d55ffe5be86b9dc0c06ebad1 /python/pyproject.toml
parent1d141195c18f7827ba1146a1fdaead2f353f85a8 (diff)
downloadsandcrawler-f67d870ba4ca9cecd0b75f106335997c813e9df4.tar.gz
sandcrawler-f67d870ba4ca9cecd0b75f106335997c813e9df4.zip
add pyproject.toml (for isort and yapf config), and update 'lint' and 'fmt' make targets
Diffstat (limited to 'python/pyproject.toml')
-rw-r--r--python/pyproject.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/python/pyproject.toml b/python/pyproject.toml
new file mode 100644
index 0000000..f7fb3bd
--- /dev/null
+++ b/python/pyproject.toml
@@ -0,0 +1,9 @@
+[build-system]
+requires = ["setuptools", "wheel"]
+build-backend = "setuptools.build_meta:__legacy__"
+
+[tool.yapf]
+COLUMN_LIMIT = 120
+
+[tool.isort]
+line_length = 120