aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorPierre Krieger <pierre.krieger1708@gmail.com>2015-05-08 15:34:56 +0200
committerPierre Krieger <pierre.krieger1708@gmail.com>2015-05-08 15:34:56 +0200
commit4086063e40ffd18369c1365fe8d8d3b87ae09f7e (patch)
tree1b2054e1630dd1aae8a88d5080088b1e59e29539 /Cargo.toml
parent479e51234e87aeef000ebaa3047c304cbe974ec1 (diff)
downloadglutin-4086063e40ffd18369c1365fe8d8d3b87ae09f7e.tar.gz
glutin-4086063e40ffd18369c1365fe8d8d3b87ae09f7e.zip
Use precise version numbers for dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 13 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0beb64b..700a4e9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,17 +15,17 @@ default = ["window"]
window = []
[dependencies]
-gl_common = "*"
-lazy_static = "0.1"
-libc = "*"
-shared_library = "0.1"
+gl_common = "0.0.4"
+lazy_static = "0.1.10"
+libc = "0.1"
+shared_library = "0.1.0"
[build-dependencies]
-gl_generator = "*"
-khronos_api = "*"
+gl_generator = "0.0.25"
+khronos_api = "0.0.5"
[dev-dependencies]
-clock_ticks = "*"
+clock_ticks = "0.0.5"
[target.arm-linux-androideabi.dependencies.android_glue]
version = "0"
@@ -50,15 +50,15 @@ kernel32-sys = "0.1"
[target.i686-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
-wayland-client = "*"
-x11-dl = "*"
+wayland-client = "0.1.3"
+x11-dl = "=1.0.1"
[target.x86_64-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
-wayland-client = "*"
-x11-dl = "*"
+wayland-client = "0.1.3"
+x11-dl = "=1.0.1"
[target.arm-unknown-linux-gnueabihf.dependencies]
osmesa-sys = "0.0.5"
-wayland-client = "*"
-x11-dl = "*"
+wayland-client = "0.1.3"
+x11-dl = "=1.0.1"