aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVictor Berger <victor.berger@m4x.org>2015-08-16 14:12:21 +0200
committerVictor Berger <victor.berger@m4x.org>2015-08-16 14:12:21 +0200
commit1cea6a65a44dee4d0bd85a35f8ac531017c4951f (patch)
treed2b999e296fea8bb3faa9b678fc93cd0a0399c4d /Cargo.toml
parentc5d11ebca2159cbd6e67b018997a2587d202f0ce (diff)
downloadglutin-1cea6a65a44dee4d0bd85a35f8ac531017c4951f.tar.gz
glutin-1cea6a65a44dee4d0bd85a35f8ac531017c4951f.zip
Update wayland backend to draw decorations.
Integrate with wayland-window crate to draw decorations allowing resize & move of the window. Leaving the wayland backend as disabled until full usability is ensured.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 8 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7f4f016..f6232f5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -75,24 +75,28 @@ dwmapi-sys = "0.1"
[target.i686-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
-wayland-client = { version = "0.2.0", features = ["egl", "dlopen"] }
+wayland-client = { version = "0.2.1", features = ["egl", "dlopen"] }
wayland-kbd = "0.2.0"
+wayland-window = "0.1.0"
x11-dl = "~2.0"
[target.x86_64-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
-wayland-client = { version = "0.2.0", features = ["egl", "dlopen"] }
+wayland-client = { version = "0.2.1", features = ["egl", "dlopen"] }
wayland-kbd = "0.2.0"
+wayland-window = "0.1.0"
x11-dl = "~2.0"
[target.arm-unknown-linux-gnueabihf.dependencies]
osmesa-sys = "0.0.5"
-wayland-client = { version = "0.2.0", features = ["egl", "dlopen"] }
+wayland-client = { version = "0.2.1", features = ["egl", "dlopen"] }
wayland-kbd = "0.2.0"
+wayland-window = "0.1.0"
x11-dl = "~2.0"
[target.aarch64-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
-wayland-client = { version = "0.2.0", features = ["egl", "dlopen"] }
+wayland-client = { version = "0.2.1", features = ["egl", "dlopen"] }
wayland-kbd = "0.2.0"
+wayland-window = "0.1.0"
x11-dl = "~2.0"