aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..01612ff
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "modelthing"
+version = "0.1.0"
+authors = ["bnewbold <bnewbold@robocracy.org>"]
+build = "src/build.rs" # eg, LALRPOP preprocessing
+
+[build-dependencies]
+lalrpop = "0.12.0"
+
+[dependencies]
+getopts = "^0.2"
+toml = "0.2"
+log = "0.3"
+env_logger = "0.3"
+lalrpop-util = "0.12"
+
+# parser util
+rustc-serialize = "0.3"
+docopt = "0.6"