aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorbnewbold <bnewbold@robocracy.org>2016-09-16 21:40:50 -0700
committerbnewbold <bnewbold@robocracy.org>2016-09-16 21:40:54 -0700
commit852b2399e7b53e1d349aed5ec9fb6550b117825c (patch)
tree647d5264e50fb8412ec0300ccab05e49351c17f9 /Cargo.toml
parentfdebceb92fe819cdcfeb9c1288102f3b97ab3ff6 (diff)
downloadmodelthing-852b2399e7b53e1d349aed5ec9fb6550b117825c.tar.gz
modelthing-852b2399e7b53e1d349aed5ec9fb6550b117825c.zip
rust parser with LALRPOP: pascal example
This is all just code from the LALRPOP library docs.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..01612ff
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "modelthing"
+version = "0.1.0"
+authors = ["bnewbold <bnewbold@robocracy.org>"]
+build = "src/build.rs" # eg, LALRPOP preprocessing
+
+[build-dependencies]
+lalrpop = "0.12.0"
+
+[dependencies]
+getopts = "^0.2"
+toml = "0.2"
+log = "0.3"
+env_logger = "0.3"
+lalrpop-util = "0.12"
+
+# parser util
+rustc-serialize = "0.3"
+docopt = "0.6"