aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorbnewbold <bnewbold@robocracy.org>2016-11-29 23:13:19 -0800
committerbnewbold <bnewbold@robocracy.org>2016-11-29 23:23:06 -0800
commita4e33306fffe87cada79c8ba47d4172d39f3fba5 (patch)
tree82aaab103a35c306177fe4c5ba2dc63cdd48d03b /Cargo.toml
parent2eb8e3e5e3d3df5ccaf5d92cb5b53cbf321688d1 (diff)
downloadmodelthing-a4e33306fffe87cada79c8ba47d4172d39f3fba5.tar.gz
modelthing-a4e33306fffe87cada79c8ba47d4172d39f3fba5.zip
first pass at pretty-printing parser errors
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3266ce5..57aa54b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,6 +14,7 @@ log = "0.3"
env_logger = "0.3"
lalrpop-util = "^0.12.4"
markdown = "0.1"
+colored = "1.3"
# parser util
rustc-serialize = "0.3"
@@ -21,3 +22,8 @@ docopt = "0.6"
# webface
pencil = "0.3"
+
+
+[features]
+# this effectively enables the feature `no-color` of colored when testing
+test = ["colored/no-color"]