aboutsummaryrefslogtreecommitdiffstats
path: root/rust/fatcat-openapi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/fatcat-openapi/Cargo.toml')
-rw-r--r--rust/fatcat-openapi/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/rust/fatcat-openapi/Cargo.toml b/rust/fatcat-openapi/Cargo.toml
new file mode 100644
index 00000000..835b9a8b
--- /dev/null
+++ b/rust/fatcat-openapi/Cargo.toml
@@ -0,0 +1,43 @@
+[package]
+name = "fatcat-openapi"
+version = "0.3.0"
+authors = ["Bryan Newbold <bnewbold@archive.org>"]
+description = "HTTP API models, endpoints, and other auto-generated types"
+license = "CC-0"
+
+[features]
+default = ["client", "server"]
+client = ["serde_json", "serde_ignored", "hyper", "hyper-openssl", "uuid"]
+server = ["serde_json", "serde_ignored", "hyper", "iron", "router", "bodyparser", "urlencoded", "uuid"]
+
+[dependencies]
+# Required by example server.
+#
+chrono = { version = "0.4", features = ["serde"] }
+futures = "0.1"
+hyper = {version = "0.10", optional = true}
+hyper-openssl = {version = "0.2", optional = true }
+iron = {version = "0.6", optional = true}
+swagger = "0.7"
+
+# Not required by example server.
+#
+bodyparser = {version = "0.8", optional = true}
+url = "1.5"
+lazy_static = "0.2"
+log = "0.3.0"
+multipart = {version = "0.13", optional = true}
+router = {version = "0.6", optional = true}
+serde = "1.0"
+serde_derive = "1.0"
+serde_ignored = {version = "0.0.4", optional = true}
+serde_json = {version = "1.0", optional = true}
+urlencoded = {version = "0.6", optional = true}
+uuid = {version = "0.5", optional = true, features = ["serde", "v4"]}
+# ToDo: this should be updated to point at the official crate once
+# https://github.com/RReverser/serde-xml-rs/pull/45 is accepted upstream
+
+
+[dev-dependencies]
+clap = "2.25"
+error-chain = "0.11"