aboutsummaryrefslogtreecommitdiffstats
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2019-01-09 14:57:56 -0800
committerBryan Newbold <bnewbold@robocracy.org>2019-01-09 14:57:56 -0800
commit995a6dcc8939aa8dcc8927ce18c9cd1ba0fd9473 (patch)
tree4521ba5aa9a6eb78803124249987e785e9aa8317 /rust/Cargo.toml
parent4461380eb79e6854352174769abde946c49c6138 (diff)
downloadfatcat-995a6dcc8939aa8dcc8927ce18c9cd1ba0fd9473.tar.gz
fatcat-995a6dcc8939aa8dcc8927ce18c9cd1ba0fd9473.zip
add sentry rust dep
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml13
1 files changed, 2 insertions, 11 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
index 2d35dc6f..a8e0e827 100644
--- a/rust/Cargo.toml
+++ b/rust/Cargo.toml
@@ -37,19 +37,10 @@ slog = "^2.0"
slog-term = "*"
slog-async = "*"
serde_json = "1.0"
+sentry = { version = "^0.12", default-features = false, features = ["with_client_implementation", "with_backtrace", "with_panic", "with_log", "with_rust_info", "with_error_chain"] }
+#cadence = "^0.16"
# Command-line tools
crossbeam-channel = "0.2"
num_cpus = "1"
env_logger = "*"
-
-# Unused (hyper 0.11 and https)
-#hyper-openssl = {version = "0.2", optional = true}
-#hyper-tls = {version = "0.1.2", optional = true}
-#tokio-core = "0.1.6"
-#tokio-proto = "0.1.1"
-
-# TODO
-#sentry = "*"
-#cadence = "*"
-#frank_jwt = "*"