aboutsummaryrefslogtreecommitdiffstats
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2019-01-09 23:52:37 -0800
committerBryan Newbold <bnewbold@robocracy.org>2019-01-09 23:52:37 -0800
commit67c3460d251a4e559a1126b5fe66fe996f840010 (patch)
tree89f0a5f37809a9b439435b9245844d1da18dc483 /rust/Cargo.toml
parenta192b0b84e46179a8f28218dfcbb5eb4e28dbf9d (diff)
downloadfatcat-67c3460d251a4e559a1126b5fe66fe996f840010.tar.gz
fatcat-67c3460d251a4e559a1126b5fe66fe996f840010.zip
HUGE refactor of error types (to use failure)
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
index a8e0e827..77eb962a 100644
--- a/rust/Cargo.toml
+++ b/rust/Cargo.toml
@@ -15,7 +15,6 @@ diesel = { version = "1.3", features = ["postgres", "uuid", "serde_json", "chron
diesel_migrations = "1.3"
dotenv = "0.9.0"
clap = "2"
-error-chain = "0.12"
uuid = "0.6"
log = "*"
data-encoding = "2.1"
@@ -24,6 +23,7 @@ lazy_static = "1.0"
sha1 = { version = "0.6", features = ["std"] }
macaroon = { git = "https://github.com/bnewbold/libmacaroon-rs", branch = "bnewbold-broken" }
rand = "*"
+failure = "*"
# API server
chrono = { version = "0.4", features = ["serde"] }
@@ -37,7 +37,7 @@ slog = "^2.0"
slog-term = "*"
slog-async = "*"
serde_json = "1.0"
-sentry = { version = "^0.12", default-features = false, features = ["with_client_implementation", "with_backtrace", "with_panic", "with_log", "with_rust_info", "with_error_chain"] }
+sentry = { version = "^0.12", default-features = false, features = ["with_client_implementation", "with_backtrace", "with_panic", "with_log", "with_rust_info", "with_failure"] }
#cadence = "^0.16"
# Command-line tools