aboutsummaryrefslogtreecommitdiffstats
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2018-05-15 00:51:21 -0700
committerBryan Newbold <bnewbold@robocracy.org>2018-05-15 00:51:21 -0700
commit4c90242579c1e673ae47d63786503370c512f148 (patch)
treedee5e78d8ed1c750b4d8c9c25c4bef9a673c3ca2 /rust/Cargo.toml
parent28978964a77e853031874230c2415b1b835e93fc (diff)
downloadfatcat-4c90242579c1e673ae47d63786503370c512f148.tar.gz
fatcat-4c90242579c1e673ae47d63786503370c512f148.zip
add basic slog logging
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
index 56144dd3..4e86d830 100644
--- a/rust/Cargo.toml
+++ b/rust/Cargo.toml
@@ -17,12 +17,16 @@ error-chain = "0.11"
chrono = { version = "0.4", features = ["serde"] }
futures = "0.1"
hyper = "0.10"
-#hyper-openssl = {version = "0.2", optional = true}
-#hyper-tls = {version = "0.1.2", optional = true}
iron = "0.5"
iron-slog = "*"
iron-test = "*"
swagger = "0.7"
+slog = "^2.0"
+slog-term = "*"
+slog-async = "*"
+
+#hyper-openssl = {version = "0.2", optional = true}
+#hyper-tls = {version = "0.1.2", optional = true}
#tokio-core = "0.1.6"
#tokio-proto = "0.1.1"