aboutsummaryrefslogtreecommitdiffstats
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2018-05-15 00:33:33 -0700
committerBryan Newbold <bnewbold@robocracy.org>2018-05-15 00:33:36 -0700
commit33a4cce0b97832f5f0301b318a0a50073ce6b615 (patch)
tree1b6ba7ec5944d2be2d746510e743a7934f453cd0 /rust/Cargo.toml
parent4a1d8f20ab91fda0f4794131144915d0c5214268 (diff)
downloadfatcat-33a4cce0b97832f5f0301b318a0a50073ce6b615.tar.gz
fatcat-33a4cce0b97832f5f0301b318a0a50073ce6b615.zip
revert to v2.3.1 codegen
This reverts back to something compatible with Iron and simple (blocking) parallelism, instead of the new async hyper 0.11 stuff.
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
index f35490e5..56144dd3 100644
--- a/rust/Cargo.toml
+++ b/rust/Cargo.toml
@@ -16,14 +16,15 @@ error-chain = "0.11"
# API server
chrono = { version = "0.4", features = ["serde"] }
futures = "0.1"
-hyper = "0.11"
+hyper = "0.10"
+#hyper-openssl = {version = "0.2", optional = true}
#hyper-tls = {version = "0.1.2", optional = true}
iron = "0.5"
iron-slog = "*"
iron-test = "*"
-swagger = "0.10"
-tokio-core = "0.1.6"
-tokio-proto = "0.1.1"
+swagger = "0.7"
+#tokio-core = "0.1.6"
+#tokio-proto = "0.1.1"
# TODO
#sentry = "*"