aboutsummaryrefslogtreecommitdiffstats
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2018-12-29 00:04:46 -0800
committerBryan Newbold <bnewbold@robocracy.org>2018-12-29 00:04:48 -0800
commit6e92ed37320f04b29511f6e3614086cffcab6eb0 (patch)
treebafaa4dbb2f4845b87fdee4941d2a82a3d24efd8 /rust/Cargo.toml
parent156b10220a50f6f441e7484235e227316f26761e (diff)
downloadfatcat-x-attic-auth-other-macaroon-lib.tar.gz
fatcat-x-attic-auth-other-macaroon-lib.zip
start trying 'macaroons' cratex-attic-auth-other-macaroon-lib
I initially thought that this might be better than 'macaroon'; macaroons, despite being in "archive" mode, had more crates.io downloads and I hoped might be better implemented. It seems half-complete though, and, eg, doesn't support the V2 macaroon encoding format. This patch isn't complete (didn't figure out verification), but I probably won't pursure it.
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
index a20118d2..278654b5 100644
--- a/rust/Cargo.toml
+++ b/rust/Cargo.toml
@@ -21,7 +21,7 @@ data-encoding = "2.1"
regex = "1"
lazy_static = "1.0"
sha1 = { version = "0.6", features = ["std"] }
-macaroon = { git = "https://github.com/bnewbold/libmacaroon-rs", branch = "bnewbold-broken" }
+macaroons = "0.3.3"
# API server
chrono = { version = "0.4", features = ["serde"] }