aboutsummaryrefslogtreecommitdiffstats
path: root/ANNOUNCE
diff options
context:
space:
mode:
Diffstat (limited to 'ANNOUNCE')
-rw-r--r--ANNOUNCE155
1 files changed, 85 insertions, 70 deletions
diff --git a/ANNOUNCE b/ANNOUNCE
index ec4e57b..b30a287 100644
--- a/ANNOUNCE
+++ b/ANNOUNCE
@@ -1,84 +1,99 @@
-This message announces the availability of Scheme Library release slib3a2.
+This message announces the availability of Scheme Library release slib3a3.
-It has been too long since the last release. Many bugs have been
-fixed; and support for several implementations (especially Guile,
-Scheme48) has been significantly improved. New in slib3a2:
-
- peanosfc.scm: Peano space filling curve.
-
- logical.scm: (logand, logior, logxor): Take one or more arguments.
- Refactored to match SRFI-60.
-
- All uses of CREATE-ARRAY replaced by MAKE-ARRAY (SRFI-63).
- All uses of ARRAY-SHAPE replaced with ARRAY-DIMENSIONS (SRFI-63).
-
- * subarray.scm (subarray, array-trim): Rewrote for all arrays being
- 0-based.
-
- * arraymap.scm (array-map!, array-for-each, array-index-map!):
- Use of ARRAY-DIMENSIONS replaces use of ARRAY-SHAPE.
- (make-shared-array): converted.
-
- * array.scm: Made compatible with SRFI-63.
- (equal?): Replaces array=?.
-
- pnm.scm: Finished implementation; handles 16-bit color.
-
- * colorspc.scm (read-normalized-illuminant, illuminant-map)
- (illuminant-map->XYZ): Added.
- (wavelength->CIEXYZ, XYZ:normalize, XYZ:normalize-colors)
- (temperature->CIEXYZ, spectrum->CIEXYZ, wavelength->CIEXYZ):
- Removed; use chromaticity functions instead.
- (read-cie-illuminant): Added.
-
- * ciesia.dat: Added CIE Standard Illuminant A relative spectral
- power distribution 300 nm - 830 nm at 5 nm intervals.
-
- * ciesid65.dat: Added CIE Standard Illuminant D65 relative
- spectral power distribution 300 nm - 830 nm at 5 nm intervals.
-
- * daylight.scm (sunlight-chromaticity): Replaces sunlight-CIEXYZ.
-
- * solid.scm (scene:sun, scene:overcast): Use chromaticity to
- normalize XYZ values.
- (solid:polyline): Added.
- (solid:cylinder): Negative radius for invisible side.
+SLIB is a portable Scheme library providing compatibiliy and utility
+functions for all standard Scheme implementations.
- * format.scm: Made reentrant; restored. Call slib:error for errors.
+SLIB supports the Bigloo, Chez, DrScheme, ELK, GAMBIT, Jscheme,
+MacScheme, MITScheme, PocketScheme, RScheme, Scheme->C, Scheme48, SCM,
+SCSH, T3.1, UMB-Scheme, and VSCM implementations.
- * dbutil.scm (close-database): Don't lock immutable dbs.
+SLIB is free software. It has a Permissive-Non-Warranty license
+(http://www.swiss.ai.mit.edu/~jaffer/SLIB_COPYING.txt).
- * transact.scm (word-lock:certificate): Test file's existence
- before OPEN-FILE.
+Documentation and distributions in several formats are linked from
+SLIB's home page:
- vet.scm (vet-slib): Accept file arguments to include in vetting.
+ http://swissnet.ai.mit.edu/~jaffer/SLIB.html
- * vscm.init, umbscheme.init, scsh.init, macscheme.init,
- guile.init, gambit.init, elk.init, chez.init, STk.init,
- RScheme.init, Template.scm, pscheme.init, t3.init, scheme48.init,
- scheme2c.init, s48-0_57.init, mitscheme.init, bigloo.init
- (*features*): Regularized order and content.
+Links to distributions of SLIB and related softwares are at the end of
+this message.
-=-=-
+slib3a3 news:
+
+Multi-dimensional linear interpolation and resampling of arrays are
+added. Case-folding of symbols is removed from SLIB. It should work
+with implementations which are case-sensitive when reading symbols.
+
+ * grapheps.scm (graph:plot): Plot multiple traces from array.
+ (functions->array): Generalizes graph:plot-function.
+
+ * root.scm (integer-sqrt): Changed to algorithm attributed to
+ Bradley Lucier by Steve VanDevender.
+ * slib.texi (Root Finding): integer-sqrt changed to floor of sqrt.
+
+ * linterp.scm (interpolate-array-ref, resample-array!): Added.
+
+ * bytenumb.scm (bytes->ieee-float, bytes->ieee-double)
+ (ieee-float->bytes, ieee-double->bytes): Fixed for -0.0.
+ * bytenumb.scm (ieee-float->bytes, ieee-double->bytes): Handle 0/0
+ in srfi-70 arithmetic.
+
+ * guile.init (slib:load, slib:load-from-path): Adapted patch from
+ Thomas Bushnell BSG for loading into SLIB module.
+ * guile.init (home-vicinity): Check for getenv first.
+ (*features*): Fixed array, system, etc.
+ (system->line): Fixed return status (thanks to Rob Browning).
+ (guile:wrap-case-insensitive): Removed; sources now case clean.
+ * guile.init (system->line): Added features line-i/o and hash.
+ (implementation-vicinity): Fixed to parent directory of ice-9.
+ * guile.init (sub-vicinity): Downcased software-type symbols.
+
+ * dirs.scm, transact.scm, batch.scm, prec.scm,
+ Template.scm, *.init: Downcased all software-type symbols.
+ * require.scm, mklibcat.scm, mkclrnam.scm, alistab.scm, Makefile:
+ Downcased *slib-version* symbol.
+
+ * top-refs.scm (top-refs:expression): Check for lists before
+ walking CASE and COND clauses (srfi-61.scm macro broke it).
+
+ * http-cgi.scm (query-alist->parameter-list): Fixed order of nary
+ fields.
+ * http-cgi.scm (http:status-line): Changed to HTTP-1.0; works
+ better in MS-Windows.
+ * db2html.scm (command:make-editable-table): Boolean "arity".
+
+ * peanosfc.scm (peano-coordinates->natural)
+ (natural->peano-coordinates): Non-negative versions.
+ * phil-spc.scm (hilbert-coordinates->integer): nbits calculation
+ was missing (incorrectly used rank).
+ (bitwise-laminate, bitwise-delaminate): Removed unused functions.
+
+ * slib.texi (SRFI): Added table mapping SRFI to feature.
+ (Scheme Syntax Extension Packages): Moved most SRFIs here.
+ * srfi.scm: Removed comments about copyright.
+ * mklibcat.scm (and-let*, receive, define-record-type)
+ (guarded-cond-clause): Added aliases for srfi-2, srfi-8, srfi-9,
+ and srfi-61.
+ * Makefile (srfiles): Most srfi-* moved from txiscms.
+ (srfiles): Added srfi-61.
+
+ * slib.spec: Updated from RedHat version from Jindrich Novy.
+ * slib.spec (%post): Commented out install-info.
+ * slib.spec (install): Make slib executable.
+ * slib.spec: Fixed for rpmbuild version 4.3.1
+ * Makefile (rpm): Program name changed to rpmbuild.
+
+From: Ivan Shmakov
+ * srfi-61.scm (cond): Added extension.
-SLIB is a portable Scheme library providing compatibiliy and utility
-functions for all standard Scheme implementations.
-
-SLIB includes initialization files for Bigloo, Chez, DrScheme, ELK,
-GAMBIT, Jscheme, MacScheme, MITScheme, PocketScheme, RScheme,
-Scheme->C, Scheme48, SCM, SCSH, T3.1, UMB-Scheme, and VSCM.
-
-Documentation includes a manifest, installation instructions, and
-coding guidelines for the library. Documentation of each library
-package is supplied. SLIB Documentation is online at:
-
- http://swissnet.ai.mit.edu/~jaffer/SLIB.html
+ -=-=-
SLIB is available from:
- http://swissnet.ai.mit.edu/ftpdir/scm/slib3a2.zip
- http://swissnet.ai.mit.edu/ftpdir/scm/slib-3a2-1.noarch.rpm
- swissnet.ai.mit.edu:/pub/scm/slib3a2.zip
- swissnet.ai.mit.edu:/pub/scm/slib-3a2-1.noarch.rpm
+ http://swissnet.ai.mit.edu/ftpdir/scm/slib3a3.zip
+ http://swissnet.ai.mit.edu/ftpdir/scm/slib-3a3-1.noarch.rpm
+ swissnet.ai.mit.edu:/pub/scm/slib3a3.zip
+ swissnet.ai.mit.edu:/pub/scm/slib-3a3-1.noarch.rpm
SLIB-PSD is a portable debugger for Scheme (requires emacs editor):
http://swissnet.ai.mit.edu/ftpdir/scm/slib-psd1-3.tar.gz