aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog11
-rw-r--r--debian/control2
-rw-r--r--require.scm7
3 files changed, 11 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 04ace0c..32887a8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+slib (3a4-4) unstable; urgency=medium
+
+ * Medium urgency because this fixes a release critical bug.
+
+ * require.scm: Revert change from 3a4-2.
+ * debian/control (slib): Conflict with scm (<< 5e3). (Closes: #397529)
+
+ -- Thomas Bushnell, BSG <tb@debian.org> Wed, 8 Nov 2006 00:06:50 -0800
+
slib (3a4-3) unstable; urgency=high
* slib.texi: Alter copyright notice to specify that there are no
@@ -7,7 +16,7 @@ slib (3a4-3) unstable; urgency=high
-- Thomas Bushnell, BSG <tb@debian.org> Wed, 1 Nov 2006 21:54:30 -0800
slib (3a4-2) unstable; urgency=low
-
+
* guile.init (library-vicinity): Set default location of slib to
/usr/share/slib instead of /usr/lib/slib.
* RScheme.init (library-vicinity): Likewise.
diff --git a/debian/control b/debian/control
index 74d61c0..602f040 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Package: slib
Section: devel
Priority: optional
Architecture: all
-Conflicts: libguile9 (<= 1:1.4-26), guile-1.6-libs (<= 1.6.7-1.1)
+Conflicts: libguile9 (<= 1:1.4-26), guile-1.6-libs (<= 1.6.7-1.1), scm (<< 5e3)
Description: Portable Scheme library
SLIB is a portable scheme library meant to provide compatibility and
utility functions for all standard scheme implementations. SLIB
diff --git a/require.scm b/require.scm
index d9edb91..31d922d 100644
--- a/require.scm
+++ b/require.scm
@@ -19,13 +19,6 @@
;@
(define *slib-version* "3a4")
-;;;; Accommodate scm versions < 5e3 which set *features* but not
-;;;; slib:features
-;;;; -- tb@debian.org, 10/24/2006
-(if (and (eq? (scheme-implementation-type) 'SCM)
- (not (defined? slib:features)))
- (define slib:features *features*))
-
;;;; MODULES
;@
(define *catalog* #f)