aboutsummaryrefslogtreecommitdiffstats
path: root/wttree.scm
diff options
context:
space:
mode:
authorJim Pick <jim@jimpick.com>1998-03-08 23:05:22 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:27 -0800
commitb21cac3362022718634f7086964208b2eed8e897 (patch)
tree16f4b2e70645c0e8e2202023170b5a94baa967e3 /wttree.scm
parent3796d2595035e192ed4bf1c9a6bfdb13c3c9d261 (diff)
parentf24b9140d6f74804d5599ec225717d38ca443813 (diff)
downloadslib-b21cac3362022718634f7086964208b2eed8e897.tar.gz
slib-b21cac3362022718634f7086964208b2eed8e897.zip
Import Debian changes 2c0-3debian/2c0-3
slib (2c0-3) unstable; urgency=low * New maintainer. * slibconfig script to automatically configure guile. * Fix type in description, closes: Bug#18996 slib (2c0-2) unstable; urgency=low * Minor fix for debian/rules targets slib (2c0-1) unstable; urgency=low * New upstream source * New maintainer
Diffstat (limited to 'wttree.scm')
-rw-r--r--wttree.scm24
1 files changed, 15 insertions, 9 deletions
diff --git a/wttree.scm b/wttree.scm
index 467aa86..7cfa85e 100644
--- a/wttree.scm
+++ b/wttree.scm
@@ -56,14 +56,6 @@
;;
;; It has been tested on MIT-Scheme, scheme48 and scm4e1
;;
-;; Non-standard procedures:
-;; error
-;; error:wrong-type-argument
-;; error:band-range-argument
-;; These are only called when there is an error so it is not critical to
-;; have them defined :-)
-;;
-;;
;; If your system has a compiler and you want this code to run fast, you
;; should do whatever is necessary to inline all of the structure accessors.
;;
@@ -71,6 +63,20 @@
;;
;;(declare (usual-integrations))
+(define error
+ (case (scheme-implementation-type)
+ ((MITScheme) error)
+ (else slib:error)))
+(define error:wrong-type-argument
+ (case (scheme-implementation-type)
+ ((MITScheme) error:wrong-type-argument)
+ (else (lambda (arg1 arg2 arg3)
+ (slib:error 'wrong-type-argument arg1 arg2 arg3)))))
+(define error:bad-range-argument
+ (case (scheme-implementation-type)
+ ((MITScheme) error:bad-range-argument)
+ (else (lambda (arg1 arg2)
+ (slib:error 'bad-range-argument arg1 arg2)))))
;;;
;;; Interface to this package.
@@ -127,7 +133,7 @@
(define fix:+ +)
(define fix:- -)
(define fix:< <)
- (define fix:<= <)
+ (define fix:<= <=)
(define fix:> >)
(define fix:* *)