aboutsummaryrefslogtreecommitdiffstats
path: root/withfile.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2007-12-28 16:25:32 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commitd8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch)
treeb20b8bc02e854c4c86d39ee22a0638a8b06e01af /withfile.scm
parentedd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff)
parent64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff)
downloadslib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz
slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low * New upstream release. * slib.texi (Library Catalogs): Repeat change from 3a3-3. * Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1. * guile.init: (library-vicinity): Repeat change from 3a4-2. * debian/rules (binary-indep): Don't hide .init files in a separate subdirectory, thus conforming better to the usual slib practice. Put a symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'withfile.scm')
-rw-r--r--withfile.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/withfile.scm b/withfile.scm
index f9e7226..fd527f8 100644
--- a/withfile.scm
+++ b/withfile.scm
@@ -1,5 +1,5 @@
; "withfile.scm", with-input-from-file and with-output-to-file for Scheme
-; Copyright (c) 1992, 1993 Aubrey Jaffer
+; Copyright (c) 1992, 1993, 2007 Aubrey Jaffer
;
;Permission to copy this software, to modify it, to redistribute it,
;to distribute modified versions, and to use it for any purpose is
@@ -42,41 +42,41 @@
(lambda() (set! withfile:current-output oport))))
;@
(define peek-char
- (let ((peek-char peek-char))
+ (let ((pk-chr peek-char))
(lambda opt
- (peek-char (if (null? opt) withfile:current-input (car opt))))))
+ (pk-chr (if (null? opt) withfile:current-input (car opt))))))
;@
(define read-char
- (let ((read-char read-char))
+ (let ((rd-chr read-char))
(lambda opt
- (read-char (if (null? opt) withfile:current-input (car opt))))))
+ (rd-chr (if (null? opt) withfile:current-input (car opt))))))
;@
(define read
- (let ((read read))
+ (let ((rd read))
(lambda opt
- (read (if (null? opt) withfile:current-input (car opt))))))
+ (rd (if (null? opt) withfile:current-input (car opt))))))
;@
(define write-char
- (let ((write-char write-char))
+ (let ((wrt-chr write-char))
(lambda (obj . opt)
- (write-char obj (if (null? opt) withfile:current-output (car opt))))))
+ (wrt-chr obj (if (null? opt) withfile:current-output (car opt))))))
;@
(define write
- (let ((write write))
+ (let ((wrt write))
(lambda (obj . opt)
- (write obj (if (null? opt) withfile:current-output (car opt))))))
+ (wrt obj (if (null? opt) withfile:current-output (car opt))))))
;@
(define display
- (let ((display display))
+ (let ((dspl display))
(lambda (obj . opt)
- (display obj (if (null? opt) withfile:current-output (car opt))))))
+ (dspl obj (if (null? opt) withfile:current-output (car opt))))))
;@
(define newline
- (let ((newline newline))
+ (let ((nwln newline))
(lambda opt
- (newline (if (null? opt) withfile:current-output (car opt))))))
+ (nwln (if (null? opt) withfile:current-output (car opt))))))
;@
(define force-output
- (let ((force-output force-output))
+ (let ((frc-otpt force-output))
(lambda opt
- (force-output (if (null? opt) withfile:current-output (car opt))))))
+ (frc-otpt (if (null? opt) withfile:current-output (car opt))))))