aboutsummaryrefslogtreecommitdiffstats
path: root/uri.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /uri.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'uri.txi')
-rw-r--r--uri.txi18
1 files changed, 18 insertions, 0 deletions
diff --git a/uri.txi b/uri.txi
index 8e785a7..18fdef1 100644
--- a/uri.txi
+++ b/uri.txi
@@ -22,11 +22,13 @@ described in RFC 2396.
Returns a Uniform Resource Identifier string from component arguments.
@end defun
+
@defun uri:make-path path
Returns a URI string combining the components of list @var{path}.
@end defun
+
@defun html:anchor name
Returns a string which defines this location in the (HTML) file
as @var{name}. The hypertext @samp{<A HREF="#@var{name}">} will link to this point.
@@ -38,6 +40,7 @@ as @var{name}. The hypertext @samp{<A HREF="#@var{name}">} will link to this po
@end example
@end defun
+
@defun html:link uri highlighted
Returns a string which links the @var{highlighted} text to @var{uri}.
@@ -48,17 +51,20 @@ Returns a string which links the @var{highlighted} text to @var{uri}.
@end example
@end defun
+
@defun html:base uri
Returns a string specifying the @dfn{base} @var{uri} of a document, for
@cindex base
inclusion in the HEAD of the document (@pxref{HTML, head}).
@end defun
+
@defun html:isindex prompt
Returns a string specifying the search @var{prompt} of a document, for
inclusion in the HEAD of the document (@pxref{HTML, head}).
@end defun
+
@defun uri->tree uri-reference base-tree
@@ -87,17 +93,20 @@ string.
@end example
@end defun
+
@defun uri:split-fields txt chr
Returns a list of @var{txt} split at each occurrence of @var{chr}. @var{chr} does not
appear in the returned list of strings.
@end defun
+
@defun uri:decode-query query-string
Converts a @dfn{URI} encoded @var{query-string} to a query-alist.
@cindex URI
@end defun
+
@noindent @code{uric:} prefixes indicate procedures dealing with
URI-components.
@@ -110,17 +119,20 @@ Returns a copy of the string @var{uri-component} in which all @dfn{unsafe} octet
@code{uric:decode} decodes strings encoded by @code{uric:encode}.
@end defun
+
@defun uric:decode uri-component
Returns a copy of the string @var{uri-component} in which each @samp{%} escaped
characters in @var{uri-component} is replaced with the character it encodes. This
routine is useful for showing URI contents on error pages.
@end defun
+
@defun uri:path->keys path-list ptypes
@var{path-list} is a path-list as returned by @code{uri:split-fields}. @code{uri:path->keys}
returns a list of items returned by @code{uri:decode-path}, coerced
to types @var{ptypes}.
@end defun
+
@subheading File-system Locators and Predicates
@@ -128,6 +140,7 @@ to types @var{ptypes}.
Returns a URI-string for @var{path} on the local host.
@end defun
+
@defun absolute-uri? str
Returns #t if @var{str} is an absolute-URI as indicated by a
syntactically valid (per RFC 2396) @dfn{scheme}; otherwise returns
@@ -135,20 +148,24 @@ syntactically valid (per RFC 2396) @dfn{scheme}; otherwise returns
#f.
@end defun
+
@defun absolute-path? file-name
Returns #t if @var{file-name} is a fully specified pathname (does not
depend on the current working directory); otherwise returns #f.
@end defun
+
@defun null-directory? str
Returns #t if changing directory to @var{str} would leave the current
directory unchanged; otherwise returns #f.
@end defun
+
@defun glob-pattern? str
Returns #t if the string @var{str} contains characters used for
specifying glob patterns, namely @samp{*}, @samp{?}, or @samp{[}.
@end defun
+
@noindent
Before RFC 2396, the @dfn{File Transfer Protocol} (FTP) served a
@cindex File Transfer Protocol
@@ -176,3 +193,4 @@ remote-site
remote-directory
@end enumerate
@end defun
+