aboutsummaryrefslogtreecommitdiffstats
path: root/tsort.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /tsort.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'tsort.scm')
-rw-r--r--tsort.scm58
1 files changed, 53 insertions, 5 deletions
diff --git a/tsort.scm b/tsort.scm
index 9371f3c..9db98f2 100644
--- a/tsort.scm
+++ b/tsort.scm
@@ -1,7 +1,6 @@
;;; "tsort.scm" Topological sort
;;; Copyright (C) 1995 Mikael Djurfeldt
-;
-; This code is in the public domain.
+;;; This code is in the public domain.
;;; The algorithm is inspired by Cormen, Leiserson and Rivest (1990)
;;; "Introduction to Algorithms", chapter 23
@@ -9,7 +8,57 @@
(require 'hash-table)
(require 'primes)
-(define (topological-sort dag pred)
+;;@code{(require 'topological-sort)} or @code{(require 'tsort)}
+;;@ftindex topological-sort
+;;@ftindex tsort
+
+;;@noindent
+;;The algorithm is inspired by Cormen, Leiserson and Rivest (1990)
+;;@cite{Introduction to Algorithms}, chapter 23.
+
+;;@body
+;;@defunx topological-sort dag pred
+;;where
+;;@table @var
+;;@item dag
+;;is a list of sublists. The car of each sublist is a vertex. The cdr is
+;;the adjacency list of that vertex, i.e. a list of all vertices to which
+;;there exists an edge from the car vertex.
+;;@item pred
+;;is one of @code{eq?}, @code{eqv?}, @code{equal?}, @code{=},
+;;@code{char=?}, @code{char-ci=?}, @code{string=?}, or @code{string-ci=?}.
+;;@end table
+;;
+;;Sort the directed acyclic graph @1 so that for every edge from
+;;vertex @var{u} to @var{v}, @var{u} will come before @var{v} in the
+;;resulting list of vertices.
+;;
+;;Time complexity: O (|V| + |E|)
+;;
+;;Example (from Cormen):
+;;@quotation
+;;Prof. Bumstead topologically sorts his clothing when getting
+;;dressed. The first argument to @0 describes which
+;;garments he needs to put on before others. (For example,
+;;Prof Bumstead needs to put on his shirt before he puts on his
+;;tie or his belt.) @0 gives the correct order of dressing:
+;;@end quotation
+;;
+;;@example
+;;(require 'tsort)
+;;@ftindex tsort
+;;(tsort '((shirt tie belt)
+;; (tie jacket)
+;; (belt jacket)
+;; (watch)
+;; (pants shoes belt)
+;; (undershorts pants shoes)
+;; (socks shoes))
+;; eq?)
+;;@result{}
+;;(socks undershorts pants shoes watch shirt belt tie jacket)
+;;@end example
+(define (tsort dag pred)
(if (null? dag)
'()
(let* ((adj-table (make-hash-table
@@ -42,5 +91,4 @@
(visit (car def) (cdr def)))))
(cdr dag)))
sorted)))
-
-(define tsort topological-sort)
+(define topological-sort tsort)