aboutsummaryrefslogtreecommitdiffstats
path: root/trnscrpt.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /trnscrpt.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'trnscrpt.scm')
-rw-r--r--trnscrpt.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/trnscrpt.scm b/trnscrpt.scm
index 3f2c8a1..aaec7cb 100644
--- a/trnscrpt.scm
+++ b/trnscrpt.scm
@@ -8,7 +8,7 @@
;1. Any copy made of this software must include this copyright notice
;in full.
;
-;2. I have made no warrantee or representation that the operation of
+;2. I have made no warranty or representation that the operation of
;this software will be error-free, and I am under no obligation to
;provide any services, by way of maintenance, update, or otherwise.
;
@@ -18,15 +18,15 @@
;each case.
(define transcript:port #f)
-
+;@
(define (transcript-on filename)
(set! transcript:port (open-output-file filename)))
-
+;@
(define (transcript-off)
(if (output-port? transcript:port)
(close-output-port transcript:port))
(set! transcript:port #f))
-
+;@
(define read-char
(let ((read-char read-char) (write-char write-char))
(lambda opt
@@ -35,7 +35,7 @@
((output-port? transcript:port)
(write-char ans transcript:port)))
ans))))
-
+;@
(define read
(let ((read read) (write write) (newline newline))
(lambda opt
@@ -46,28 +46,28 @@
(if (eqv? #\newline (apply peek-char opt))
(newline transcript:port))))
ans))))
-
+;@
(define write-char
(let ((write-char write-char))
(lambda (obj . opt)
(apply write-char obj opt)
(if (output-port? transcript:port)
(write-char obj transcript:port)))))
-
+;@
(define write
(let ((write write))
(lambda (obj . opt)
(apply write obj opt)
(if (output-port? transcript:port)
(write obj transcript:port)))))
-
+;@
(define display
(let ((display display))
(lambda (obj . opt)
(apply display obj opt)
(if (output-port? transcript:port)
(display obj transcript:port)))))
-
+;@
(define newline
(let ((newline newline))
(lambda opt