aboutsummaryrefslogtreecommitdiffstats
path: root/transact.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /transact.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'transact.txi')
-rw-r--r--transact.txi6
1 files changed, 6 insertions, 0 deletions
diff --git a/transact.txi b/transact.txi
index 5e3ff8f..4dec378 100644
--- a/transact.txi
+++ b/transact.txi
@@ -55,6 +55,7 @@ Returns the string @samp{@var{user}@@@var{hostname}} associated with
the lock owner of file @var{path} if locked; and #f otherwise.
@end defun
+
@deffn {Procedure} file-lock! path email
@@ -69,6 +70,7 @@ unlocked, then @code{file-lock!} returns the certificate string associated with
new lock for file @var{path}.
@end deffn
+
@deffn {Procedure} file-unlock! path certificate
@var{path} must be a string naming the file to be unlocked. @var{certificate} must be the
@@ -78,6 +80,7 @@ If @var{path} is locked with @var{certificate}, then @code{file-unlock!} removes
@samp{#t}. Otherwise, @code{file-unlock!} leaves the file system unaltered and returns
@samp{#f}.
@end deffn
+
@subsubheading File Transactions
@@ -104,6 +107,7 @@ the string "@var{path}.bak"
@end table
@end defun
+
@defun transact-file-replacement proc path backup-style certificate
@@ -140,6 +144,7 @@ returns a string, then @var{path} is renamed to it.
Finally, the temporary file is renamed @var{path}.
@code{transact-file-replacement} returns #t if @var{path} was successfully replaced; and #f otherwise.
@end defun
+
@subsubheading Identification
@@ -148,3 +153,4 @@ Finally, the temporary file is renamed @var{path}.
@code{user-email-address} returns a string of the form @samp{username@r{@@}hostname}. If
this e-mail address cannot be obtained, #f is returned.
@end defun
+