summaryrefslogtreecommitdiffstats
path: root/trace.scm
diff options
context:
space:
mode:
authorJim Pick <jim@jimpick.com>1998-03-08 23:05:22 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:27 -0800
commitb21cac3362022718634f7086964208b2eed8e897 (patch)
tree16f4b2e70645c0e8e2202023170b5a94baa967e3 /trace.scm
parent3796d2595035e192ed4bf1c9a6bfdb13c3c9d261 (diff)
parentf24b9140d6f74804d5599ec225717d38ca443813 (diff)
downloadslib-debian/2c0-3.tar.gz
slib-debian/2c0-3.zip
Import Debian changes 2c0-3debian/2c0-3
slib (2c0-3) unstable; urgency=low * New maintainer. * slibconfig script to automatically configure guile. * Fix type in description, closes: Bug#18996 slib (2c0-2) unstable; urgency=low * Minor fix for debian/rules targets slib (2c0-1) unstable; urgency=low * New upstream source * New maintainer
Diffstat (limited to 'trace.scm')
-rw-r--r--trace.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/trace.scm b/trace.scm
index d595277..2ffeaed 100644
--- a/trace.scm
+++ b/trace.scm
@@ -25,7 +25,10 @@
(not not) ;tracef will not trace parts
(car car) (cdr cdr) ;of itself.
(eq? eq?) (+ +) (zero? zero?) (modulo modulo)
- (apply apply) (display display) (qpn qpn))
+ (apply apply) (display display) (qpn qpn)
+
+ (CALL (string->symbol "CALL"))
+ (RETN (string->symbol "RETN")))
(lambda (function . optname)
(set! debug:indent 0)
(let ((name (if (null? optname) function (car optname))))
@@ -36,12 +39,12 @@
function)
(else
(do ((i debug:indent (+ -1 i))) ((zero? i)) (display #\ ))
- (apply qpn "CALLED" name args)
+ (apply qpn CALL name args)
(set! debug:indent (modulo (+ 1 debug:indent) 8))
(let ((ans (apply function args)))
(set! debug:indent (modulo (+ -1 debug:indent) 8))
(do ((i debug:indent (+ -1 i))) ((zero? i)) (display #\ ))
- (qpn "RETURNED" name ans)
+ (qpn RETN name ans)
ans))))))))
;;; the reason I use a symbol for debug:untrace-object is so