aboutsummaryrefslogtreecommitdiffstats
path: root/synclo.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /synclo.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'synclo.scm')
-rw-r--r--synclo.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/synclo.scm b/synclo.scm
index 5883b93..5c7bb9f 100644
--- a/synclo.scm
+++ b/synclo.scm
@@ -20,7 +20,7 @@
;;; software shall duly acknowledge such use, in accordance with the
;;; usual standards of acknowledging credit in academic research.
;;;
-;;; 4. MIT has made no warrantee or representation that the operation
+;;; 4. MIT has made no warranty or representation that the operation
;;; of this software will be error-free, and MIT is under no
;;; obligation to provide any services, by way of maintenance, update,
;;; or otherwise.
@@ -194,7 +194,7 @@
(define syntactic-closure-type
(make-record-type "syntactic-closure" '(ENVIRONMENT FREE-NAMES FORM)))
-
+;@
(define make-syntactic-closure
(record-constructor syntactic-closure-type '(ENVIRONMENT FREE-NAMES FORM)))
@@ -230,7 +230,7 @@
result)))
(else
object)))
-
+;@
(define (identifier? object)
(or (symbol? object)
(synthetic-identifier? object)))
@@ -246,7 +246,7 @@
(identifier->symbol (syntactic-closure/form identifier)))
(else
(impl-error "not an identifier" identifier))))
-
+;@
(define (identifier=? environment-1 identifier-1 environment-2 identifier-2)
(let ((item-1 (syntactic-environment/lookup environment-1 identifier-1))
(item-2 (syntactic-environment/lookup environment-2 identifier-2)))
@@ -541,7 +541,7 @@
((definition-item/binding-theory item)
environment
(definition-item/name item)
- (promise:force (definition-item/value item))))
+ (force (definition-item/value item))))
(define (syntactic-binding-theory environment name item)
(if (or (keyword-item? item)
@@ -684,7 +684,7 @@
(for-each (lambda (name)
(syntactic-environment/define! environment name item))
names)))
-
+;@
(define (capture-syntactic-environment expander)
(classifier->form
(lambda (form environment definition-environment)