aboutsummaryrefslogtreecommitdiffstats
path: root/strsrch.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /strsrch.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'strsrch.scm')
-rw-r--r--strsrch.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/strsrch.scm b/strsrch.scm
index 7773e51..13edb65 100644
--- a/strsrch.scm
+++ b/strsrch.scm
@@ -6,7 +6,7 @@
; This code is in the public domain.
;;;@ Return the index of the first occurence of chr in str, or #f
-(define (strsrch:string-index str chr)
+(define (string-index str chr)
(define len (string-length str))
(do ((pos 0 (+ 1 pos)))
((or (>= pos len) (char=? chr (string-ref str pos)))
@@ -34,7 +34,7 @@
(cond ((zero? patlen) 0) ; trivial match
((>= patlen strlen) (and (= patlen strlen) (string=? pat str) 0))
;; use faster string-index to match a single-character pattern
- ((= 1 patlen) (strsrch:string-index str (string-ref pat 0)))
+ ((= 1 patlen) (string-index str (string-ref pat 0)))
((or (<= strlen (+ patlen patlen (quotient char-code-limit 2)))
(<= patlen 4))
(subloop pat patlen str strlen char=?))
@@ -55,7 +55,7 @@
(define strlen (string-length str))
(cond ((zero? patlen) 0) ; trivial match
((>= patlen strlen) (and (= patlen strlen) (string-ci=? pat str) 0))
- ((= 1 patlen) (strsrch:string-index-ci str (string-ref pat 0)))
+ ((= 1 patlen) (string-index-ci str (string-ref pat 0)))
((or (<= strlen (+ patlen patlen (quotient char-code-limit 2)))
(<= patlen 4))
(subloop pat patlen str strlen char-ci=?))