aboutsummaryrefslogtreecommitdiffstats
path: root/strport.scm
diff options
context:
space:
mode:
authorJim Pick <jim@jimpick.com>1998-03-08 23:05:22 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:27 -0800
commitb21cac3362022718634f7086964208b2eed8e897 (patch)
tree16f4b2e70645c0e8e2202023170b5a94baa967e3 /strport.scm
parent3796d2595035e192ed4bf1c9a6bfdb13c3c9d261 (diff)
parentf24b9140d6f74804d5599ec225717d38ca443813 (diff)
downloadslib-b21cac3362022718634f7086964208b2eed8e897.tar.gz
slib-b21cac3362022718634f7086964208b2eed8e897.zip
Import Debian changes 2c0-3debian/2c0-3
slib (2c0-3) unstable; urgency=low * New maintainer. * slibconfig script to automatically configure guile. * Fix type in description, closes: Bug#18996 slib (2c0-2) unstable; urgency=low * Minor fix for debian/rules targets slib (2c0-1) unstable; urgency=low * New upstream source * New maintainer
Diffstat (limited to 'strport.scm')
-rw-r--r--strport.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/strport.scm b/strport.scm
index 54d8d39..a75ab0a 100644
--- a/strport.scm
+++ b/strport.scm
@@ -33,7 +33,7 @@
(cond ((eof-object? c)
(set! s (string-append s (substring buf 0 i))))
((>= i 512)
- (set! s (string-append s buf))
+ (set! s (string-append s buf (string c)))
(loop 0))
(else
(string-set! buf i c)