aboutsummaryrefslogtreecommitdiffstats
path: root/srfi-2.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /srfi-2.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'srfi-2.scm')
-rw-r--r--srfi-2.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/srfi-2.scm b/srfi-2.scm
new file mode 100644
index 0000000..adb2530
--- /dev/null
+++ b/srfi-2.scm
@@ -0,0 +1,41 @@
+;;"srfi-2.scm": Guarded LET* special form
+;Copyright (C) 2003 Aubrey Jaffer
+;
+;Permission to copy this software, to modify it, to redistribute it,
+;to distribute modified versions, and to use it for any purpose is
+;granted, subject to the following restrictions and understandings.
+;
+;1. Any copy made of this software must include this copyright notice
+;in full.
+;
+;2. I have made no warranty or representation that the operation of
+;this software will be error-free, and I am under no obligation to
+;provide any services, by way of maintenance, update, or otherwise.
+;
+;3. In conjunction with products arising from the use of this
+;material, there shall be no use of my name in any advertising,
+;promotional, or sales literature without prior written consent in
+;each case.
+
+;;@code{(require 'srfi-2)}
+;;@ftindex srfi-2
+
+;;@body
+;;@url{http://srfi.schemers.org/srfi-2/srfi-2.html}
+(defmacro and-let* (claws . body)
+ (define (andin claw ans)
+ (if (and (pair? ans) (eq? 'and (car ans)))
+ `(and ,claw ,@(cdr ans))
+ `(and ,claw ,ans)))
+ (do ((claws (reverse claws) (cdr claws))
+ (ans (cond ((null? body) '(and))
+ ((null? (cdr body)) (car body))
+ (else (cons 'begin body)))
+ (let ((claw (car claws)))
+ (cond ((symbol? claw)
+ (andin claw ans))
+ ((and (pair? claw) (null? (cdr claw)))
+ (andin (car claw) ans))
+ (else
+ `(let (,claw) ,(andin (car claw) ans)))))))
+ ((null? claws) ans)))