aboutsummaryrefslogtreecommitdiffstats
path: root/srfi-11.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2007-12-28 16:25:32 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commitd8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch)
treeb20b8bc02e854c4c86d39ee22a0638a8b06e01af /srfi-11.scm
parentedd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff)
parent64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff)
downloadslib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz
slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low * New upstream release. * slib.texi (Library Catalogs): Repeat change from 3a3-3. * Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1. * guile.init: (library-vicinity): Repeat change from 3a4-2. * debian/rules (binary-indep): Don't hide .init files in a separate subdirectory, thus conforming better to the usual slib practice. Put a symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'srfi-11.scm')
-rw-r--r--srfi-11.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/srfi-11.scm b/srfi-11.scm
new file mode 100644
index 0000000..366e12e
--- /dev/null
+++ b/srfi-11.scm
@@ -0,0 +1,38 @@
+;;; This code is in the public domain.
+;;; http://srfi.schemers.org/srfi-11/srfi-11.html
+;;; by Lars T. Hansen 1999
+
+(define-syntax let-values
+ (syntax-rules ()
+ ((let-values (?binding ...) ?body0 ?body1 ...)
+ (let-values "bind" (?binding ...) () (begin ?body0 ?body1 ...)))
+
+ ((let-values "bind" () ?tmps ?body)
+ (let ?tmps ?body))
+
+ ((let-values "bind" ((?b0 ?e0) ?binding ...) ?tmps ?body)
+ (let-values "mktmp" ?b0 ?e0 () (?binding ...) ?tmps ?body))
+
+ ((let-values "mktmp" () ?e0 ?args ?bindings ?tmps ?body)
+ (call-with-values
+ (lambda () ?e0)
+ (lambda ?args
+ (let-values "bind" ?bindings ?tmps ?body))))
+
+ ((let-values "mktmp" (?a . ?b) ?e0 (?arg ...) ?bindings (?tmp ...) ?body)
+ (let-values "mktmp" ?b ?e0 (?arg ... x) ?bindings (?tmp ... (?a x)) ?body))
+
+ ((let-values "mktmp" ?a ?e0 (?arg ...) ?bindings (?tmp ...) ?body)
+ (call-with-values
+ (lambda () ?e0)
+ (lambda (?arg ... . x)
+ (let-values "bind" ?bindings (?tmp ... (?a x)) ?body))))))
+
+(define-syntax let*-values
+ (syntax-rules ()
+ ((let*-values () ?body0 ?body1 ...)
+ (begin ?body0 ?body1 ...))
+
+ ((let*-values (?binding0 ?binding1 ...) ?body0 ?body1 ...)
+ (let-values (?binding0)
+ (let*-values (?binding1 ...) ?body0 ?body1 ...)))))