aboutsummaryrefslogtreecommitdiffstats
path: root/srfi-1.txi
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /srfi-1.txi
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'srfi-1.txi')
-rw-r--r--srfi-1.txi86
1 files changed, 81 insertions, 5 deletions
diff --git a/srfi-1.txi b/srfi-1.txi
index a27fcc1..4b2ed74 100644
--- a/srfi-1.txi
+++ b/srfi-1.txi
@@ -23,6 +23,10 @@ Returns a list of length @var{len}. Element @var{i} is @code{(@var{proc}
@end defun
+@defun list-copy flist
+
+@end defun
+
@defun iota count start step
@@ -66,7 +70,22 @@ Returns a circular list of @var{obj1}, @var{obj2}, @dots{}.
@defun first pair
-@defunx fifth obj
+
+@end defun
+
+@defun second pair
+
+@end defun
+
+@defun third pair
+
+@end defun
+
+@defun fourth pair
+
+@end defun
+
+@defun fifth pair
@defunx sixth obj
@defunx seventh obj
@defunx eighth obj
@@ -79,19 +98,35 @@ Returns a circular list of @var{obj1}, @var{obj2}, @dots{}.
@end defun
-@defun take lst k
-@defunx drop lst k
+@defun drop lst k
+@defunx take lst k
@end defun
+@deffn {Procedure} take! lst k
+
+@end deffn
+
@defun take-right lst k
@end defun
+@defun drop-right lst k
+
+@end defun
+
+@deffn {Procedure} drop-right! lst k
+
+@end deffn
+
@defun split-at lst k
@end defun
+@deffn {Procedure} split-at! lst k
+
+@end deffn
+
@defun last lst
(car (last-pair lst))
@@ -108,9 +143,9 @@ Returns a circular list of @var{obj1}, @var{obj2}, @dots{}.
@end defun
-@defun reverse! lst
+@deffn {Procedure} reverse! lst
-@end defun
+@end deffn
@defun append-reverse rev-head tail
@defunx append-reverse! rev-head tail
@@ -134,8 +169,28 @@ Returns a circular list of @var{obj1}, @var{obj2}, @dots{}.
@end defun
@subheading Fold and Unfold
+
+@deffn {Procedure} map! f list1 clist2 @dots{}
+
+@end deffn
+
+@defun pair-for-each f clist1 clist2 @dots{}
+
+@end defun
@subheading Filtering and Partitioning
+
+@defun filter pred lis
+
+@end defun
+
+@deffn {Procedure} filter! pred l
+
+@end deffn
+
+@defun partition pred list
+
+@end defun
@subheading Searching
@@ -147,6 +202,26 @@ Returns a circular list of @var{obj1}, @var{obj2}, @dots{}.
@end defun
+@defun remove pred l
+
+@end defun
+
+@deffn {Procedure} remove! pred l
+
+@end deffn
+
+@defun any pred clist1 clist2 @dots{}
+
+@end defun
+
+@defun list-index pred clist1 clist2 @dots{}
+
+@end defun
+
+@defun span pred list
+
+@end defun
+
@defun member obj list pred
@@ -176,3 +251,4 @@ returns that pair. If no pair in @var{alist} has @var{obj} as its car, then @t{
testing equality. If @var{pred} is not provided, @samp{equal?} is used.
@end defun
@subheading Set operations
+