aboutsummaryrefslogtreecommitdiffstats
path: root/soundex.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /soundex.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'soundex.scm')
-rw-r--r--soundex.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/soundex.scm b/soundex.scm
index eb3a542..6d73341 100644
--- a/soundex.scm
+++ b/soundex.scm
@@ -8,16 +8,16 @@
; Taken from Knuth, Vol. 3 "Sorting and searching", pp 391--2
(require 'common-list-functions)
-
+;@
(define SOUNDEX
(let* ((letters-to-omit
- (list #\A #\E #\H #\I #\O #\U #\W #\Y))
+ (list #\A #\E #\H #\I #\O #\U #\W #\Y))
(codes
(list (list #\B #\1)
(list #\F #\1)
(list #\P #\1)
(list #\V #\1)
- ;
+ ;;
(list #\C #\2)
(list #\G #\2)
(list #\J #\2)
@@ -26,19 +26,19 @@
(list #\S #\2)
(list #\X #\2)
(list #\Z #\2)
- ;
+ ;;
(list #\D #\3)
(list #\T #\3)
- ;
+ ;;
(list #\L #\4)
- ;
+ ;;
(list #\M #\5)
(list #\N #\5)
- ;
+ ;;
(list #\R #\6)))
(xform
(lambda (c)
- (let ((code (assq c codes)))
+ (let ((code (assv c codes)))
(if code
(cadr code)
c)))))
@@ -50,10 +50,10 @@
(string->list name)))))
(if (null? char-list)
name
- (let* (; Replace letters except first with codes:
+ (let* ( ;; Replace letters except first with codes:
(n1 (cons (car char-list) (map xform char-list)))
- ; If 2 or more letter with same code are adjacent
- ; in the original name, omit all but the first:
+ ;; If 2 or more letter with same code are adjacent
+ ;; in the original name, omit all but the first:
(n2 (let loop ((chars n1))
(cond ((null? (cdr chars))
chars)
@@ -62,14 +62,14 @@
(cadr chars))
(loop (cdr chars))
(cons (car chars) (loop (cdr chars))))))))
- ; Omit vowels and similar letters, except first:
+ ;; Omit vowels and similar letters, except first:
(n3 (cons (car char-list)
(remove-if
(lambda (c)
- (memq c letters-to-omit))
+ (memv c letters-to-omit))
(cdr n2)))))
- ;
- ; pad with 0's or drop rightmost digits until of form "annn":
+ ;;
+ ;; pad with 0's or drop rightmost digits until of form "annn":
(let loop ((rev-chars (reverse n3)))
(let ((len (length rev-chars)))
(cond ((= 4 len)