summaryrefslogtreecommitdiffstats
path: root/slib.spec
diff options
context:
space:
mode:
authorJames LewisMoss <dres@debian.org>2001-07-27 23:45:29 -0400
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:29 -0800
commitf559c149c83da84d0b1c285f0298c84aec564af9 (patch)
treef1c91bcb9bb5e6dad87b643127c3f878d80d89ee /slib.spec
parentc394920caedf3dac1981bb6b10eeb47fd6e4bb21 (diff)
parent87b82b5822ca54228cfa6df29be3ad9d4bc47d16 (diff)
downloadslib-debian/2d2-1.tar.gz
slib-debian/2d2-1.zip
Import Debian changes 2d2-1debian/2d2-1
slib (2d2-1) unstable; urgency=low * New upstream version * Revert back to free. Is now so. slib (2d1-1) unstable; urgency=low * New upstream version. * Move to non-free. FSF pointed out license doesn't allow modified versions to be distributed. * Get a complete list of copyrights that apply to the source into copyright file. * Remove setup for guile 1.3. * Remove postrm. Just calling install-info (lintian) Move install-info call to prerm since doc-base doesn't do install-info. slib (2c9-3) unstable; urgency=low * Change info location to section "The Algorithmic Language Scheme" to match up with where guile puts it's files. * Postinst is running slibconfig now. (Closes: #75891) slib (2c9-2) unstable; urgency=low * Stop installing slibconfig (for guile). * In postinst if /usr/sbin/slibconnfig exists call it (Close: #75843 #75891). slib (2c9-1) unstable; urgency=low * New upstream (Closes: #74760) * replace string-index with strsrch:string-index in http-cgi.scm. * Add doc-base support (Closes: #31163)
Diffstat (limited to 'slib.spec')
-rw-r--r--slib.spec97
1 files changed, 97 insertions, 0 deletions
diff --git a/slib.spec b/slib.spec
new file mode 100644
index 0000000..38e425a
--- /dev/null
+++ b/slib.spec
@@ -0,0 +1,97 @@
+%define name slib
+%define version 2d2
+%define release 1
+
+Name: %{name}
+Release: %{release}
+Version: %{version}
+Packager: Radey Shouman <shouman@ne.mediaone.net>
+
+Copyright: distributable, see individual files for copyright
+Vendor: Aubrey Jaffer <agj @ alum.mit.edu>
+Group: Development/Tools
+Provides: slib
+BuildArch: noarch
+
+Summary: platform independent library for scheme
+Source: ftp://swissnet.ai.mit.edu/pub/scm/slib%{version}.zip
+URL: http://swissnet.ai.mit.edu/~jaffer/SLIB.html
+BuildRoot: %{_tmppath}/%{name}%{version}
+Prefix: /usr/share
+
+%description
+"SLIB" is a portable library for the programming language Scheme.
+It provides a platform independent framework for using "packages" of
+Scheme procedures and syntax. As distributed, SLIB contains useful
+packages for all Scheme implementations. Its catalog can be
+transparently extended to accomodate packages specific to a site,
+implementation, user, or directory.
+
+%define __os_install_post /usr/lib/rpm/brp-compress
+
+%prep
+%setup -n slib -c -T
+cd ..
+unzip $RPM_SOURCE_DIR/slib%{version}.zip
+
+%build
+gzip -f slib.info
+
+%install
+mkdir -p ${RPM_BUILD_ROOT}%{prefix}/slib
+cp -r . ${RPM_BUILD_ROOT}%{prefix}/slib
+mkdir -p ${RPM_BUILD_ROOT}/usr/info
+cp slib.info.gz ${RPM_BUILD_ROOT}/usr/info
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+/sbin/install-info /usr/info/slib.info.gz /usr/info/dir
+
+# This symlink is made as in the spec file of Robert J. Meier.
+if [ -L /usr/share/guile/slib ]; then
+ rm /usr/share/guile/slib
+ ln -s %{prefix}/slib /usr/share/guile/slib
+fi
+
+# This section should be extended to rebuild catalogs for as many
+# implementations as possible.
+if type guile; then
+ guile -c "(use-modules (ice-9 slib)) (require 'new-catalog)"
+fi
+if type scm; then
+ scm -c "(require 'new-catalog)"
+fi
+if type umb-scheme; then
+ SCHEME_INIT=${SCHEME_LIBRARY_PATH}umbscheme.init
+ echo "(require 'new-catalog)" | umb-scheme
+fi
+if type mzscheme; then
+ SCHEME_LIBRARY_PATH=`pwd`/
+ rm /usr/local/lib/plt-103/slibcat
+ mzscheme -L init.ss slibinit -e "(require 'new-catalog)"
+fi
+if type scheme48; then
+ make install48
+fi
+
+%files
+%defattr(-, root, root)
+%dir %{prefix}/slib
+%{prefix}/slib/*.scm
+%{prefix}/slib/*.init
+/usr/info/slib.info.gz
+# The Makefile is included as it is useful for building documentation.
+%{prefix}/slib/Makefile
+%doc ANNOUNCE README COPYING FAQ ChangeLog
+
+%changelog
+* Wed Mar 14 2001 Radey Shouman <shouman@ne.mediaone.net>
+- Adapted from the spec file of R. J. Meier.
+
+* Mon Jul 12 2000 Dr. Robert J. Meier <robert.meier@computer.org> 0.9.4-1suse
+- Packaged for SuSE 6.3
+
+* Sun May 30 2000 Aubrey Jaffer <agj @ alum.mit.edu>
+- Updated content